Setup OpenWRT for PPPoE with Vigor 130, Telekom DSL

Hello,

I am on 23.05 and trying to connect to the internet using a Linksys WRT1200AC and Draytek Vigor 130 firmware 3.8.5.1 v7 (Deutsche Telekom Version). The Internet works with another router and the same modem and credentials. The vlan tagging is enabled in the modem, unfortunately I don't get a connection. Anyone any suggestions what I need to make it work? I also disabled vlan flagging in the modem but was still not able to make it work trying to flag the connection in openwrt.

The PPPoE Authentification fails.

This is my openwrt network config:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4c:e3ef:0e64::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '62:38:e0:d9:2c:55'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username '*@t-online.de'
        option password '*'
        option ipv6 'auto'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

might want to post relevant parts from dmesg ....

1 Like

I have tried your explanation but was not able to make it work unfortunately.

I will try to do that, any more specific dmesg options and arguments?

Where did it fail?

Okay I got it workig thanks to your guide. Set up the vigor exactly like you and modified your Config like this:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '*::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '*'

config interface 'wan'
        option proto 'pppoe'
        option username '*@t-online.de'
        option password '*'
        option force_link '1'
        option ipv6 'auto'
        option delegate '0'
        option device 'wan.7'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option device 'wan'

config interface 'modem'
        option proto 'static'
        option device 'wan'
        option ipaddr '192.168.2.2'
        option netmask '255.255.255.0'
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.