Setup multiple PPPoE connections over one wan interface

Hi,
I'm trying to use one wan interface to connect multiple PPPoE connections to my isp.
for testing and easier debugging i created a similar environment using virtualbox, 2 VMs:
1- a mikrotik chr server set up as a PPPoE server with two profiles(users) ppp1 and ppp2
2- an openwrt vm set up as a PPPoE client

both VMs are on the same internal network (intnet).

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd82:30f5:5008::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.100.2'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'pppoe1'
        option proto 'pppoe'
        option ifname 'eth1'
        option type 'bridge'
        option username 'ppp1'
        option ipv6 'auto'
        option password '123'

config interface 'pppoe2'
        option proto 'pppoe'
        option ifname 'eth1'
        option type 'bridge'
        option username 'ppp2'
        option ipv6 'auto'
        option password '123'

config device 'veth0'
        option name 'veth0'
        option type 'macvlan'
        option ifname 'eth1'

config device 'veth1'
        option name 'veth1'
        option type 'macvlan'
        option ifname 'eth1'

The result is that only one PPPoE gets connected successfully and the other one shows " Error: Network device is not present"

So how can i setup multiple PPPoE connections on the same WAN interface ?

Regards

any help, please?!