Setup HH5a with Plusnet

I've successfully managed to install OpenWrt on my BT Home Hub 5a router and I can access it via LuCi. I'm trying to replace my Plusnet router with this one but I can't seem to get it to connect to my Plusnet fibre broadband. I've plugged in the cable from the phone socket, and setup the WAN settings with PPPoE, username of @plusdsl.net, and the password, but it never seems to connect. Is there any other config I need to do to get this all working? I was wondering if I need to do something to get the internal modem setup perhaps?

Have you checked this
https://openwrt.org/docs/guide-user/network/wan/isp-configurations#united_kingdom

Excellent, thanks for that, looks like just what I need. I'll give it a try tonight.

fwiw, refer to section 7.5 and 9.1 of the install guide
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266

Great, thanks.

I've tried applying the settings as suggested and I still don't seem to have an internet connection. I've got a feeling that the connection is made to the ISP but it's not making it through to the LAN. I can see the uptime counter counting on the WAN, but still no internet access on my laptop connected to the wifi.

Some suggestions:

Does WAN in LuCI-> Network -> Interfaces show IPv4 address supplied by Plusnet?

Note that Plusnet does not use IPv6. Have you deleted the WAN6 interface to avoid possible issues?

Have you tried a different device?

Have you tried connecting via ethernet?

On Windows, use the following command from 'cmd' box to report IP address, gateway (192.168.1.1) and DNS (192.168.1.1).

ipconfig /all

can you ping 192.168.1.1, 8.8.8.8 and 'www.bbc.co.uk' from cmd box and get any reply?

You can easily check that by trying to ping a public IP (e.g. 8.8.8.8) and a domain (e.g. openwrt.org) from the router itself via LuCI or SSH connection.

Thanks for the suggestions, sorry it took me a while to try them.

I think I was wrong about the wan connection having the uptime counter, it just shows this:
Protocol: PPPoE
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)
Error: Unknown error (AUTH_TOPEER_FAILED)

I can't see the IPv4 address from Plusnet anywhere, I've deleted WAN6 with no effect, same issues from another device. Ipconfig shows ip address as 192.168.1.229, default gateway as 192.168.1.1

I can ping 192.168.1.1, but not the external ip or domain name.

What is the output of:
/etc/init.d/dsl_control status

this is to check whether there is actual sync on the dsl link. I simply assume the plusnet calls fiber to the cabinet fibre and just assumes that the last meters in coper from the cabinet to the modem do need no mentioning...

You don't appear to have any WAN connection to Plusnet.

Do you have line sync (ie. what is the Data Rate) as displayed in Luci -> Status -> Overview page?

fwiw, I suggest you factory reset the hub as described in section 8 in the hh5a install guide, and start over and follow instructions as described in 7.5/9.1 for FTTC.

If you still have problems and you are a Windows user, you can refer to section 10 and post contents of /etc/config/network file (remove your username & password) so we can check for errors.

btw, your Plusnet username is in the format myname@plusdsl.net

Because the PPPoE authentication fails in the first place. You could get more verbose PPP logging by enabling its debug option in /etc/ppp/options

- #debug
+ debug