Setup an Odroid H2+ with OpenWrt

Thanks for the image, but i get no output at all only a blinking blank on the top left corner. Is that normal?
Maybe the file got corrupted?
Name: openwrt-x86-64-generic-squashfs-combined-efi.img.gz
Size: 61803134 Bytes (58 MiB)
SHA256: ABCC5DFF28475DB21593F392305D86A21ED703C7FFD5A592316CC43ED7BD9FFA

Try the efi.img inside the .gz file. Sometimes I wasn't able to use the .gz file for some reason.

If using etcher, I have better success just flashing it twice but my USB ports aren't great either. Occasionally on my first boot after flashing with etcher It wouldn't detect the emmc i was using and a reboot would usually solve that and then I'd see Loading OpenWRT or something similar.

I tried efi.img and efi.img.gz with Etcher to a USB Stick and a SSD with no success

The H2+ will be supported with kernel 5.10, update the latest BIOS if you have the new odroid H2 net card.

kernel 5.4 realtek driver 9.005.01

kernel 5.11 r8169 driver

Thanks for the images, they recongnize the NICs. But the NICs are down and it won't go beyond this screen.

How do I interact with OpenWRT in this state?

did you connect the ethernet cable to the LAN port on your PC?

Yes i tried that and than i tried to connect all 6 interfaces to a switch to see if ones comes up. But all stayed down.

What BIOS version are you using ?

root@OpenWrt:~# dmesg | grep DMI
[    0.000000] DMI: HARDKERNEL ODROID-H2/ODROID-H2, BIOS 1.22 11/13/2020 any other bios wouldn't recongnize all NICs

Try using the the keyboard and reset it
firstboot && reboot now

nothing happens, it does not boot far enough to have a shell. So everything beside ctrl + alt + delete to reboot gets ignored

what boot media are you uisng USB, eMMC or SATA disk?

I tried a USB Stick and a SSD with a USB to sata adapter

Ok i found out that the problem was indeed the two devices, i tried it with a very old 8GB USB stick instead of the 128 GB one and the SSD and that worked. That is strange, Opnsense did boot from that SSD with the adapter just fine.

So after using the kernel 5.11 r8169 driver version a bit.
NAT throughput is 1,84 Gbit/s
Forwarding IPv6 is limited by the 2,5 Gbit/s Interface.
only strange thing is that the latency is terrible.
Ping to the Modem takes 2ms more vs direct attached, my Turris Omnia took for the same routing only 0,2ms.
If that get fixed somehow it is the perfect router.

How do i get the latest version of openwrt with 5.11 kernel and r8169 drivers odroid h2+?

I pulled github openwrt on my ubuntu host and ran make menu. But can't seem to find the things i need to select for 5.11 kernel and r8169 drivers.

I was hoping someone would post a image but none so far that i can find work for me. using Odroid H2+ with a sata ssd and the 4 port 2.5g nic.

Any help appreciated.

be aware that only one nic will be on the OpenWRT LAN bridge, so you have to connect to that to be able to do anything and there is no DHCP, so you have to set a static IP on your computer to access
For me it was that port

Sadly i can't help you with building a image with a mainline kernel because i don't understand how to do that also but I'm very interested in that too because i would need btrfs which is not included in the image from @mj82
If mj82 could share how to build a image I would be very happy.

1 Like

PR3989, but 5.10 as that it the next LTS.

1 Like

I did build a image from that PR and can confirm that it does work.
If anyone want to test it, it is pretty minimal and only includes what i need currently.
SHA256: F21AB945BE1A94543AC66F684CF744115E0C342F081B65DE1A2CF113983103A0
SHA256: A2FAFB24AD72FEC981667B90361769E90C44B31FCEFCBACBCF208E6C03D82128

For those who want to use 19.07.7 with rtl8125b, I compiled an efi firmware with r8125b driver from realtek website, driver version is 9.005.01.

Openwrt kernel vermagic number is the same with the official 19.07.7 firmware, so you can use opkg to install packages and kernel mods