hi everyone.
I have recently had some problems with my WRT1900AC (v2) and decided to upgrade to a GL-MT6000. Since the MT6000 became my router, i want to repurpose the wrt1900ac as a wifi repeater to better reach some parts of the house. I am trying to do so for 2.4ghz band only (so i'll leave 5ghz out of the configs below).
To achieve this, i followed this wiki guide and it doesn't seem to be working. Here's the wireless config on the MT6000 router:
/etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option channel '1'
option band '2g'
option htmode 'HE20'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'mySSID'
option encryption 'sae'
option key 'myPassword'
option wds '1'
As per the wiki, the ip address
command should display a new network interface. In my case no new network interfaces were created
And here are the configs on the WRT1900AC repeater:
/etc/config/dhcp
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option ignore '1'
/etc/config/network
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option ip6assign '60'
/etc/config/wireless
config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option channel '1'
option band '2g'
option htmode 'HT20'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'sta'
option ssid 'mySSID'
option encryption 'sae'
option macaddr 'myMacAddr'
option wds '1'
option key 'myPassword'
config wifi-iface 'default_clone'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'mySSID'
option encryption 'sae'
option key 'myPassword'
When connected to the repeater using an ethernet cable, i SSH into the repeater itself and i am unable to ping the router at 192.168.1.1, which tells me the connection isn't working. I'm also not seeing the repeater in the list of connected clients on the router's LuCI. Could someone provide some help please? I've tried everything, even doing it through LuCI itself but no luck