Setting Up OperWRT Router to use 4G Network

Hi everybody,

Nice to meet you guys. I apologize in advance if I am asking some noob questions here. It is my first time dealing with OpenWrt.

I got a device from a broadband service provider which I stopped subscribing because they are too expensive.

I reset my router to factory default to erase the service provider's configuration. However, I am struggling to improve my internet download speed. I inserted a SIM card into the router for internet, but while it connects to the ISP, the internet speed is very slow.

When I use the same SIM card in my phone, the download speed is over 100 Mbps. However, in the router, the speed drops to around 1 Mbps. I have been searching on Google for two days but haven't found a solution.

I'm unsure whether the issue is due to hardware limitations of the device or a problem with the OpenWrt configuration. Could you provide some guidance on how to determine the cause and find a solution?

I would greatly appreciate your suggestions.

Thanks,

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

2 Likes

Hi frolic,

Thank you so much for the prompt reply and the direction given. The device I have is an OEM device from some random manufacturer from China. I tried the model number doesn't match any of OpenWrt in the list. May I know how do I identify the right official firmware version that would work on my device?

Thanks again,
CK

no idea, we don't know anything about your TR110 device, nor any "official firmware".

Hi frolic,

Thanks again.

If the SIM is set up on a plan intended for phones or tablets, the ISP may detect that you are using a router and degrade the service (slow speed, limited GB per month, and/or no service at all).

The MT7628 is not a fast chip. For triple-digit speeds you will need different hardware.

2 Likes

Hi mk24,

Thank you for the tips. I think I will listen to your suggestion and get a new device.

Best,
CK