Setting up Bluetooth connection between Raspberry Pi and RUTX11

Hello guys!

I urgently need help in sending data between raspberry pi and RUTX11 Bluetooth router.
I successfully paired raspberry pi with RUTX11, but whenever i try to connect and send data, it shows an error.
The library i am using on RUTX11 is "bluez-daemon", i am pairing using bluetoothctl
On Raspberry pi, i am pairing in the same way, using bluetoothctl.
I also installed "blueman" on raspberry pi to be able to send data to the router, however i am not succeeding.
I am not familiar with bluez-daemon or bluetoothctl, your help would be really appreciated.

Check attached for more info.

You don’t appear to be using openwrt. That looks like the standard raspberry pi os. You should ask on their support forums.

1 Like

I am using Openwrt on the RUTX11 part, i am showing you that if i try to send a file from raspberry pi to RUTX11 it won't work...
I tried sending a file from Raspberry pi to my phone and it worked, so i guess the problem is on the router.

What is the output of the following?

ubus call system board


You appear to have a vendor specific firmware that is based on openwrt, but is not part of the official openwrt project. It is likely highly customized by the vendor. You should ask the vendor for support.

1 Like