Setting pppoe auth timeout

On a device running barrier breaker I need to set a pppoe auth timeout value as currently have the following on constant loop

Plugin loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Send PPPOE Discovery V1T1 PADI session 0x0 length 12
PADS: Service-Name: 'pppoe'
PPP session is 49545
Connected to x via interface eth1
using channel 7969
Using interface pppoe-wan
Connect: pppoe-wan <--> eth1
sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8cdaf93d>]
rcvd [LCP ConfReq id=0x1 <mru 1492> <auth chap MD5> <magic 0xc0689d93>]
sent [LCP ConfAck id=0x1 <mru 1492> <auth chap MD5> <magic 0xc0689d93>]
rcvd [LCP ConfAck id=0x1 <mru 1492> <magic 0x8cdaf93d>]
sent [LCP EchoReq id=0x0 magic=0x8cdaf93d]
rcvd [LCP EchoReq id=0x0 magic=0xc0689d93]
sent [LCP EchoRep id=0x0 magic=0x8cdaf93d]
rcvd [CHAP Challenge id=0xf0 <941e96f79766fc8d3db3c435d9dd3083d451f5a1a52c>, name = "sbips-net-003"]
sent [CHAP Response id=0xf0 <a227c25f39b2280a88e523ba4b005575>, name = "username"]
rcvd [LCP EchoRep id=0x0 magic=0xc0689d93]
rcvd [CHAP Failure id=0xf0 "Access denied"]
CHAP authentication failed: Access denied
CHAP authentication failed
sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
rcvd [LCP TermReq id=0x2 "Authentication failed"]
sent [LCP TermAck id=0x2]
rcvd [LCP TermAck id=0x2]
Connection terminated.

I've tried setting various implementations of following values in /etc/ppp/options and /etc/config/network but none appear to have any effect.

option keepalive '3 2'
option persist '1'
option holdoff '5'
option maxfail '0’

Basically I just want to try auth 2 times then wait 10 minutes before trying again for a further 2 times and so on.

First of all, are you sure you can connect at all?
What happens, for example, if you stop the interface, wait 10 minutes and only then restart it?
I'm asking so we don't chase the wrong problem

EDIT: /etc/config/network for PPPOE connections apparently only supports "keepalive", the other option should be fed directly to ppp, without the "option" keyword.

Yes if i set the correct password it connects fine. I'm accounting for incorrect password.

If I if down the interface it's bought up again automatically on the next 'cycle'

So the remaining issue is the reconnect cycle that's too short, right? Then try splliting the options this way:


persist 1
holdoff 5
maxfail 0


config interface 'wan'
        option proto 'pppoe'
        option keepalive '3 2'