Set Up a modem ZTE F660 with a LEDE Router WR1043ND V2.0

Hello I am trying to configure my home network with the previously mentioned hardware an ISP provided ZTE F660 modem and my own Router a WR1043ND V2.0, the thing is that I can't put my modem in bridge mode I've tried but can't, if anyone knows how to do it will be greatly appreciated, on the other hand the more accessible way is to used both, but can't figure out to set them up correctly. I can create a double NAT with them and I am pleased with the SQM of LEDE, but I can't open the ports for any of the aplications of my network, and when I disable the DCHP from the router I lose the wonderful SQM but I can freely open up ports from the modem. So that's the problem any sort of help is greatly appreciated. Thanks

Do you have user and password for configuration? try:

user: admin
password: Ql52jP23

if you had no success try searching again: and add the name of your ISP (since some ISP put their own credentials/password)

Some ISP will re-configure your bridged modem again to routed mode... you will need to disable TR-069 or similar, ISP use that to reconfigure or firmware upgrade your Modem at any time they want... If not ultimately you will need to call them and ask they for bridge mode, with or without public IP, they could ask you to rent a public IP address too.

If you don't see any "mode" switch, you probably will need to disable WiFi, disable DHCP, disable NAT, (usually this three things are needed in order to get public WAN in port 1.

It is FTTH (gpon - fiber optic) right ?, you probably will need to configure proper static IP, subnet Mask, Gateway and DNS on WAN interface of the LEDE Router and connect it to the LAN Port labeled 1 on the ZTE, in order to get internet when bridge mode is enabled on the ZTE.

Take in mind that you may get a different IP in WAN than public (using for example) this is common for home users recently because IPv4 addesses space is fully populated and ISP are doing NAT on their ends, you will open and forward TPC-UDP ports only using IPv6.

Thanks for your reply, I have every single password to configure the F660 in bridge mode, but reading the forums from people who have this modem, I am informed that I can't put it in bridge mode without the permission from my isp, I also called my isp and they told me they were not currently configuring any router with FTTH into bridge mode since in my country its kind off new, any how I am looking for a way to have the SQM from lede without having to put the modem in bridge mode at least until my isp, opens up about the configuration.

You can configure SQM, but I don't know if that device will clog up even with SQM enabled on the only device connected... that should be the WR1043V2... have you tried to read some instructions to enable SQM yet? it is easy, if you need you could install luci-app-sqm using luci too and reboot.

opkg update; opkg install luci-app-sqm

you should use values at around 95% of speedtest or 85% of ISP advertised speed

# without luci:
opkg update
opkg install sqm-scripts

/etc/init.d/sqm enable
/etc/init.d/sqm start
/etc/init.d/sqm restart
# check logs just in case:
# check defaults and backup them
cat /etc/config/sqm
cp /etc/config/sqm > etc-config-sqm.bak

# example, 30Mb download, 3Mb upload
WAN_IFACE=`uci get network.wan.ifname`
BW_DOWN='30'; BW_UP='3'

uci del sqm.eth1

# important config
uci set sqm.$WAN_NAME='queue'
uci set sqm.$WAN_NAME.interface=$WAN_IFACE # wan, Default 'eth1' (Interface de WAN)
uci set sqm.$$(($BW_DOWN*1000*85/100)) # 95% of speedtest, 85% isp
uci set sqm.$WAN_NAME.upload=$(($BW_UP*1000*85/100))
# the rest:
uci set sqm.$WAN_NAME.qdisc='fq_codel' # Default 'fq_codel'
uci set sqm.$WAN_NAME.script='simple.qos' # Default 'simple.qos'
uci set sqm.$WAN_NAME.linklayer='none' # Default 'none'
uci set sqm.$WAN_NAME.qdisc_advanced='0' # Default '0'
#uci set sqm.$WAN_NAME.ingress_ecn='ECN' # Default 'ECN'
#uci set sqm.$WAN_NAME.egress_ecn='ECN' # Default 'ECN', docs stats NOECN: At low bandwidth, we recommend that you turn ECN off for the Upload (outbound, egress) direction
#uci set sqm.$WAN_NAME.qdisc_really_really_advanced='0' # Default 0
#uci set sqm.$WAN_NAME.itarget='auto' # Default 'auto'
#uci set sqm.$WAN_NAME.etarget='auto' # Default 'auto'
#uci set sqm.$WAN_NAME.overhead='0' # Default '0' # docs says for ADSL use: '44'
# Default when using luci:
uci set sqm.$WAN_NAME.verbosity='5' # Default luci 'auto'
uci set sqm.$WAN_NAME.debug_logging='0' # Default luci 'auto'
# enable it:
uci set sqm.$WAN_NAME.enabled='1' # Default luci 'auto'

/etc/init.d/sqm restart

The problem is not enabling SQM the problem is that I can't set up the modem and router combo without bridge mode so the SQM will have some sort of effect, when I activate the DCHP in the router(the one with LEDE) and go to my bufferbloat is +-5ms and then I disable DCHP and eliminate the double NAT is like the SQM turns off, and my bufferbloat in goes up to 200ms

Ah, you want to disable DHCP (actually NAT) and keep SQM enabled?

If you do so,disable the NAT, the WAN and LAN interfaces will need to be bridged in order to get access to internet, and SQM will have no effect. It will be like a Switch

I don't think there is a way to achieve transparent forwarding without kernel interface bridging. Maybe is.

What is the reason you bother about double NAT? you could use DMZ on the modem if yo need full port redirections.

The PS4 is complaining about right?

Yes actually it's primarily for a ps4 connection setup but it's tricky if I use the connection without sqm the PC gaming ping goes up, and if I enable the double nat the ps4 requires ports to be open

You could set your modem to Work as Modem instead of Router and do Router with QoS and SQM on LEDE.
or, connect your PS4 to your modem/router, and your lede to another port, and forward all ports to your PS4, and limit bandwith and connections/packets per second on LEDE, or set a script to a button or cron when you game, or even better just disconnect all other people in your house from internet when you are gaming...