Set router to client mode failed (tp link archer a7 ac1750)

Hi, I tried to set up OpenWrt to a client mode. But it failed. My router is tp link archer a7 ac1750.

I was following this instruction:

The first step " The LAN interface must be set in a different subnet than the Wi-Fi network you are connecting to." is failed. Please see the screenshots.
Basically, the new IPv4 address "" cannot be set after I click "save&apply". I tried several times and every time I saw the same error.
Any solutions? Thanks

  • Set from another network interface (if available)
  • When it returns, hit "Apply Unchecked"
  • Edit form the CLI

(There's a safety feature that reverts on changes that cause the web GUI to loose connection - editing your LAN IP inevitably is one of those tasks.)

1 Like

Or run the uci set command via cli, and reboot.

1 Like

Thanks. Will try tonight. Just one more question: after I change the IP address of the LAN, do I still choose DHCP in my computer?

Yes, unless you've disabled the dhcp in the router.

I just tried. I used ssh to connect to my router. Then, I run uci del dhcp.lan.ra_slaac
and uci set network.lan.ipaddr=''

Then, I typed "reboot". However, after reboot, lan still has the same ip address "".
Do I need to save the ip address change? If so, how? Also, do I really need to run uci del dhcp.lan.ra_slaac .


Ok. I just solved this issue by editing the /etc/config/network file. However, now, my desktop computer has an IP address "" while my laptop which connects to the same wifi has an IP address "". I have some files shared in my desktop running windows 11. But my laptop cannot find those files by visiting "". Any solutions? Thanks