Set an static ip to wan

I need to configure this configuration in my mikrotik with OpenWRT in WAN to connect to an access point, how can I configure it? If someone explains to me even with commands I don’t mind

What are the AP details?

The name of the access point - SC.NET-1

Mac of the access point - F0:9F:C2:EE:EA:4A

“My ip” -
Netmask -
And I should enable NAT

I forgot to say the Chanel is 48

Did you scan and hit "Join Network"?

  • The wizard will let you proceed to create a WWAN
  • You can then change WWAN to Static and configure it

It doesn’t work the AP has a protection and disconnects every one who has a bad conf an that happens to me. There is a way to do it over ssh? To be sure and set the config properly

Go to Network--Interfaces and edit the wan. Change the protocol to Static IP. Change the Device to Unspecified (at the top of the list). Enter your static IP settings. Set the IP to and leave Netmask blank.
Go to Network--Wireless and add an interface on the 5 GHz radio. Set the mode to Client. Set the ESSID to match the AP (use the network name -- SSID). Set the Network to wan. Click the Encryption tab and configure to match the AP. If you haven't already, click the Advanced tab at the top of the wireless page and set the Country to your country, and also set the same country on the other radio.
The network may require you to register the MAC address of your client to them to be allowed to connect.


Yes, OpenWrt config files are under /etc/config
You can manually edit them, or use the uci cli tool, then restart their services.

If your OpenWrt device does not already have a wan or wwan network, you will also need to change: