Serial install problems on NSA310

Hi, successfuly connected NSA310 to PC (win10), tried
first command:

usb reset
gives error:

-/bin/sh: usb: not found

What could be wrong? Thx in advance!
FYI: currently using firmware version : V4.70(AFK.3)

What size is your USB stick ? Is it formatted in FAT32 ? You should stop starting system in uboot. But in your case system is fully started. I hope you have serial cable ?

1 Like

usb isn't s valid command on a default install of OpenWrt.

What software are you trying to install/run?

The procedure involving usb reset is described on the devicepage.

1 Like

Thank you for your help, really appreciate your effort.
I have a 16GB USB3 Fat32 formatted flash connected to front NAS port, with two files as stated here:
There is no other disk connected to the NAS.
I have a serial cable connected to the NAS, communication is OK (using Kittty/Putty).
There is standard FW in the NAS and I want to replace it with OpenWRT.

Maybe this is it - how should I stop it? Pressing On/Off button on the NAS? When exactly?

What about serial cable ? Is it connected ?

Yep; I could interrupt the U-boot pressing esc, but usb reset gave me 0 storage devices found (USB flash is in the front). Will try more and describe my results here. Thanks:)

Maybe you have older/smaller USB flash ?

I have a 16GB FAT32 formatted disk, but who knows - will try another one...

Tried two different USB3 16GB FAT32 and one USB2 1GB FAT formatted, both USB ports with no luck:

NSA310>> usb reset
(Re)start USB...
USB:   scanning bus for devices... 1 USB Device(s) found
       scanning bus for storage devices... 0 Storage Device(s) found
NSA310>> fatload usb 1 0x1000000 u-boot.kwb
** Can't read from device 1 **

** Unable to use usb 1:1 for fatload **
NSA310>> fatload usb 0 0x1000000 u-boot.kwb
** Can't read from device 0 **

** Unable to use usb 0:1 for fatload **

There are all LEDs on and the On/Off button on the device is not responsive.

You are writing commands in the device firmware shell. These commands must be written in the uboot shell.
Below you are writing it in the uboot shell, which is the correct place.

For some reason the stock bootloader is unable to detect the USB drives you are using. I don't know why, but some people did have issues like that.

You have to transfer the files with tftp, it's a bit more annoying, I'll post instructions below.

If you install successfully with the following instructions I'll update the wiki with this additional method.

Prepare the tftp server and the files you want to transfer as described here:[]=tftp#tftp_server_on_windows
Set your PC's ethernet port to have fixed IP address and connect it with an ethernet cable to the NSA310 ethernet port.

boot the NSA310 and reach the uboot (bootloader) console by pressing a key as soon as you see the prompt.

You should see

Now write

setenv ipaddr
setenv serverip

Then you can begin the file transfer with
tftp 0x1000000 u-boot.kwb

It should show a progress bar and will tell you if the transfer was successful.

If it's good, then you can proceed with the other instructions, to install the OpenWrt uboot

nand erase 0x0 0x100000
nand write 0x1000000 0x00000 0x100000

Then write your device's mac address as written in the sticker under the NSA310 ( the AB:CD:EF:00:00:00 you see below is an example MAC address, please write your device's MAC in the terminal)

setenv ethaddr AB:CD:EF:00:00:00

Then, you can try with normal instructions as you have just installed a different uboot, that should be able to read from USB.

usb reset
fatload usb 0 0x2000000 nsa310.bin

If it fails again, you must use tftp again to load OpenWrt firmware too.

setenv ipaddr
setenv serverip
tftp 0x2000000 nsa310.bin

and then proceed with

nand erase.part ubi
nand write 0x2000000 ubi 0x600000

And OpenWrt should be installed.

Thank you very much for the instructions, I will try them and report later.

I have been trying for several hours without success (from two PCs, Win - tftpd32 + Solarwinds, Ubuntu) so the problem seems to be in the NSA310:

NSA310>> setenv ipaddr
NSA310>> setenv serverip
NSA310>> tftp 0x1000000 u-boot.kwb
Using egiga0 device
TFTP from server; our IP address is
Filename 'u-boot.kwb'.
Load address: 0x1000000
Loading: T T T T T T T T T T
Retry count exceeded; starting again

Giving up for now, maybe I'll try later.
Thanks for your help anyway!

@ir11: Any update so far?
I had the same issue like you. Using four different USB Sticks which didn't work. After that I used the "oldest" USB stick I found supporting USB 1.1 only and it worked. Unfortunately I didn't manage to test the TFTP method on the stock u-boot (thx @bobafetthotmail for the description). Suprisingly I was not able to get a network connection for TFPT, using uboot.2017.07-tld-1.nsa310...

I updated the flashing instructions, trying to collect all information I pulled from different source on one page Table of Hardware - Zyxel NSA310. As this is more or less my first entry, I am looking forward to your feedback

1 Like

Where does the information that the NSA310b image works on an 310s come from? It would surprise me if that is true, as the 310s is a different NAS, with a different SoC. At least the ZyXEL firmware cannot be exchanged.

1 Like

The 310S has the same SoC of NSA310-320-325 but its hardware config is closer to NSA320-325 (most important thing is that it's not using the silly realtek ethernet and is instead using the SoC's own ethernet controller) and should boot and mostly work with that image, as it worked on Debian back then when they were writing the device tree files for these devices,22241 and only LEDs and power button don't work (as they used different GPIO pins to operate them).

The Zyxel NAS with different SoCs (Marvell Armada) are those from NAS326 and onwards.

Another possible workaround is to use the Sata port. Format it as FAT32 and place the files in it, then

ide reset
fatload ide 0 0x2000000 nsa310.bin

should load the files from the SATA drive.

So for NSA310S I must use NSA325 OpenWrt Image? I tried NSA310b image (as written in the instructions), but Ethernet interface not working

NSA310b uses different ethernet controller so it will not work.

With NSA325 image ethernet is the same so it should work, LEDs and power button will not work.

And is there a way to get the power button working on NSA310S?