Serial Console Issues - Installing on Edgerouter 4

I'm having a lot of issues installing openwrt on my Ubiquiti Edgerouter 4 and I'm hoping for some help, please!
I've got a serial-usb cable, tried the 115200 8n1 recommended settings and regardless of which emulator I fire up (on Mac, Windows, Linux), my terminal output is always garbage.
Am I missing something obvious?
Possible funky cable? (it's new but it's one of those USB2.0-Ser! jobbies based off of the CH341SER chip)
I've tried using xterm, vt100, hex, changed baud rate, etc with same garbled output.
I know it's been done because I've followed the instructions from here (;a=commit;h=6ee3680614047f7732731ebbaac946a93ab4f693)
Really, any assistance is appreciated!

That model has a real RS-232 port. It needs a cable like is used on Cisco equipment. These are usually light blue flat cable.

It won't work with TTL levels.

While not Cisco branded, I’m sure I bought the right cable but I guess you get what you pay for.
I’ll bite the bullet and get an authentic cable.

With that said, are there other options people have had success with?

Thanks everyone!!

I don’t think it is full RS-232 either. Cisco is big enough so they have their own console cable standard called “roll over” cable. You need that sort of cable.

It worked straight away for me but with a “Cisco roll over” cable.

it needs a "RJ45 to DB9 serial console cable (rollover cable)"

The DB9 cable is easy to find since Cisco shipped one with every switch they made. Then you need a USB-DB9 serial port adapter, or an old PC with an actual DB9 port. The DB9 cable has no active electronics, it is simply a passive connector. It's called a "rollover" cable because the assignment of the pins makes it simple to create a "null modem" (Tx and Rx crossed over) version just by flipping over the flat cable before crimping on the RJ45 plug.

There are also these which combine both functions into one piece:
I don't think there is an official Cisco version of the USB to console cable. On later models as USB became the only port on a laptop, Cisco's approach was to build a USB to serial converter inside the router or switch.

1 Like

There are actually a official blue Cisco Console-to-USB cable available. But the price on that is hilarious in comparison to buy a simple unofficial Cisco console-to-USB cable.

I’ve ordered a new USB-rj45 cable with the ftdi chip as opposed to my other cable which is based on something more obscure.
The new cable is expected on Thursday. I’m hoping that one will work.
Thanks again to everyone for helping!!
Great community!

That sounds very similar as the one I have and that worked so the hope is high!

1 Like

SUCCESS: I used the USB-RJ45 serial cable with the FTDI chip.
No issues connecting now.
Thanks everyone!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.