Serial connection, TX produces 3.3V?

Hi all,
Tried to sysupgrade from LEDE to OWT 23 and the router bricked WDR4900 v1.3 (EU).
Bought USB to TTL. Followed and trusted way too much this picture

I think I may have purged the usb adapter. I was shocked when I saw GND to TX with multimeter on router, I found out TX is sitting at 3.3V while for example TP LINK 1043ND doesn't have any such voltages there on both TX and RX.
Since this goes to TX of the usb-ttl it is purged ?
And now putty shows nothing after connecting to COM port even if I move the cables a bit. Beforehand when I move them it showed some random jiberish data due to tiny voltage differences i guess , producing random data.

Is that TX voltage on router means that router is also gone ?

GND - 0V
VCC - 3.3V
RX - 2.9V
TX - 3.3V


It is not unexpected to measure up to 3.3V on rx and tx, that doesn't tell you if the device is shot or not.


I was worried because the documentation says that you will kill the usb-ttl if you put VCC (3.3v) on RX/TX so basically if TX is producing 3.3V it is the same as putting VCC ?

"Reversing Rx and Tx will not damage anything (it may will result in garbled text on your terminal), as long as the pins or holes are indeed a TTL port. If it is not a TTL port then you could probably damage your OpenWrt device, or (more commonly) burn the USB-TTL dongle."
-> source

You need to connect GND, rx and tx (and you may have to reverse rx/ tx as needed).
You mustn't ever connect the Vcc pin of your usb2serial adapter (unless you know exactly why, there are use cases for that, but not here).

The voltage on rx/ tx will naturally fluctuate between 0-3.3V (and it is expected to measure up to/ just under 3.3V on the floating rx/ tx pins of either your usb2serial adapter and the router).

1 Like

Yeah, this is what I did and I had 3 results.
First time Putty filled up the screen with "~" characters and that's it.
Second try it didn't produced anything unless i move the wires a bit and got jiberish data when moving the wires.
Further tries, putty shows nothing, like the sensory input of the usb-ttl is dead.
Have selected the correct COM port, tried different baud rates 9600 or 115200.
the usb-ttl is PL2303HX

The 3 lights of the usb adapter start when I switch off the router and when I switch it back on 2 of them stop lighting.

Try to power up the router firxt, before plugging in the USB connector of your adapter (~1s later).

Common reasons for gibberish:

  • unreliable connections (gnd in particular)
  • usb2serial having a too high voltage (you have a multimeter, so test gnd<-->rx and gnd<-->tx, neither should exceed 3.3V; gnd<--> Vcc is also an indicator)
    I'm always a tad vary when I read pl2303hx, as many of those are 5V (they can be designed correctly, but don't need to)
  • incorrect baudrate, there's no way around trying all the common choices here (9600, 19200, 57600, 115200, …)

It may still be that the router is shot for good, but I haven't seen a strong indiciation for that so far either.

Well, this one has 3V3 and 5V on the back. But as you said I have not connected those pins to any to the router. Just GND, TX and RX. The usb takes voltage out of the Laptop in this case (which is 5V) ?

I've seen some proposals here and there for soldering the 3V3 making a bridge with TX and I don't know why they do this? Should I do 3V3 bridge as well?

edit:Doing multimeter on connected usb-ttl itself with GND and other wires have the 3V range.

no need a bridge.

At the first, verify your PC is OK, plug the USB adaptor to PC, not connect router, and short the Tx/Rx wires, then run your putty, type something on keyboard, you'll receive the echo chars on screen.

1 Like

Nice troubleshooting advice.. As soon as I short them I see in putty what I write.. when detaching I can't write to putty so I guess that's what you mean.

then connect the Tx/Rx to your router, if you cannot see the router initial log print out, most of the reason is the router is dead, or connection wires is not good.

It worked !!

This is where it stucked - just to report

Flash JECED ID: 01 20 18
Reading image header...
Image Name: POWERPC OpenWrt Linux-5.15.150
Data Size: 002e84d8
Load Address: 01000000
Entry Point: 01000000
Reading image data...
Starting image...

So LEDE -> OWT 23 sysupgrade is no-no

Back to the original question, a good serial/uart-to-USB adaptor, could work OK on the TTL logic voltage of 1.8V / 3.3V / 5V, only 5V is rare on routers.

1 Like

In my case it was the pins on the PCB making bad contact.
I want to add up something valuable as well.
That chip, most of the time is aliexpress fake one. You have to find old driver from 2008/2009 that will work. If you download the official driver in Device Manager under Windows you get explanation that "This is not PL2303HX, contact your supplier" , obviously because newer driver versions stop the fake chips this way.

Thanks both slh and RadioOperator!

yes, the most of PL230x and FT232R are fake ICs in low-cost market.

CP210x and CH340G are very good.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.