Serial connection to Meraki MR18

I'got two used Meraki MR18 and I would like to install OpenWrt on them.
Unfortunately I got blocked already at the UART connection.
I've tried an USB-cable adapter as well as a "real" serial port - sadly with the same result.

After powering on I see just an unreadable scrappy screen instead of clean boot messages.

Any idea what I could try?

  • Faulty ground connection
    How exactly have you connected your serial adapter to the MR18 (Soldered wires, header pins, holding the wires by hand to the PCB pdas...)?
  • wrong serial connection settings
    With which settings are you trying to connect?
    Have you tried different settings?

I've tried almost all possible settings - current is: 115200 8/1/N/N (no flow control)

In the meantime I've found another post here.
This post was ponting me to the right direction - I do need a TTL USB converter.

Unfortunately I don't have one - but I have a bunch of Arduino Nano boards around.
So if sombody needs a really cheap USB TTL converter...

  1. just take a Arduino board (nano in my case)

  2. flash this small sketch on it:

void setup()
void loop()

  1. Connect Pin0 -> RX, Pin1 -> TX and Pin5 -> GND

  2. Plug your adrunio to your computer, identify the Com Port, connect to the Com Port und you are done if you see the "Meraki" prompt

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.