Separate eth1 and eth0 from br-lan

Hi I was wondering if it’s possible to disassemble br-lan logical interface. My br-lan is made up of eth1 and eth0. Just had a curiosity if there are able to be separated and still function.

What is in ubus call system board and cat /etc/config/network ?
Normallty you tick checkbox to bring up empty bridge and it will be available for eg guest wifi without ethernet ports.

This is hardware dependent, so the real answer depends on the question by brada4.

Most devices have a switch, so there are some constraints involved here - but you generally can (details vary, based on the hardware).

ubus call system board
{
        "kernel": "6.6.69",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 0",
        "model": "FriendlyElec NanoPi R6S",
        "board_name": "friendlyarm,nanopi-r6s",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0-rc5",
                "revision": "r28304-6dacba30a7",
                "target": "rockchip/armv8",
                "description": "OpenWrt 24.10.0-rc5 r28304-6dacba30a7",
                "builddate": "1736026537"
        }
}

[quote="brada4, post:2, topic:221675"]
cat /etc/config/network
[/quote]

 

cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdec:77db:b251::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
list ports 'eth2'

config device
option name 'eth0'
option macaddr '8e:94:49:xx:xx:xx'

config device
option name 'eth2'
option macaddr '8e:94:49:xx:xx:xx'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
list dns '1.1.1.1'
list dns '1.0.0.1'
list dns '2606:4700:4700::1111'
list dns '2606:4700:4700::1001'

config device
option name 'eth1'
option macaddr '8e:94:49:xx:xx:xx'

config interface 'wan'
option device 'eth1'
option proto 'dhcp'
option peerdns '0'
list dns '1.1.1.1'
list dns '1.0.0.1'

config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option norelease '1'
option peerdns '0'
list dns '2606:4700:4700::1111'
list dns '2606:4700:4700:

correction on openwrt rc5 it maps the ports wrong. eth1 is physically eth2 and eth2 is physically eth1. where physically wan eth2 is wan eth1