[Semi-Solved] USB3 to Ethernet using usb-storage driver?

I'm having a little bit of a bad time trying to get a TPLink UE300 USB3.0 to Gigabit Ethernet Adapter working. The thing is that is WAS working briefly, but now it's just not present or an available device.
I'm working with an x86 OpenWrt box.

The following USB related kmods are installed
kmod-usb-net-rtl8152 <<-- This is the driver for the device apparently

This is what I'm seeing in /sys/kernel/debug/usb/devices

T:  Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=5000 MxCh= 0
D:  Ver= 3.20 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 9 #Cfgs=  1
P:  Vendor=2357 ProdID=8151 Rev=30.00
S:  Manufacturer=TP-Link
S:  Product=USB 10/100/1000 LAN
S:  SerialNumber=000001
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=288mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage << WAT???
E:  Ad=84(I) Atr=02(Bulk) MxPS=1024 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS=1024 Ivl=0ms

Completely lost now, I have no idea what's going on. Any help would be appreciated.

I have these kmods installed:

kmod-usb-core - 5.4.143-1
kmod-usb-net - 5.4.143-1
kmod-usb-net-cdc-ether - 5.4.143-1
kmod-usb-net-rndis - 5.4.143-1
kmod-usb-net-rtl8152 - 5.4.143-1

... and my UE300 works like a charme (with OpenWRT 21.2.0).

Did you try to connect your UE300 to another device (laptop, PC)? Is it recognized at that device. Does it flawlessly work at the other device?

Hi, thanks for replying.

Yes, I just plugged it in my main PC. It comes up as "Ethernet 2" and does indeed work when I switch my ethernet cable into it. In fact I'm posting this with it. I tried installing the rndis kmod but that didn't help.

EDIT: Additional information. It seems that it does work, but only after a cold reboot, basically power down and power back up. Then it works. But, if I perform a soft reboot either from bash or luci, it goes away and starts using that storage driver again. Weird.

Did you reboot your router after the installation?

Yes, many, many times. I edited my post above with some more info. I think this may be some issue with the actual PC's hardware. My suspicion ts that a soft reboot is not fully resetting the device and it's goign into some kind of usb "limbo" when the system starts back up.

EDIT: Hmm, it seems that when it's not working after a reboot, simply unplugging it and plugging it back in will make it start to work. This seems to tally with my suspicion that it's not been reset properly.

EDIT2: Well, issuing the following command in bash
usbreset 2357:8151
Makes it start to work. So that's a workaround for now, I can just have that command run after startup and all should work.

EDIT3: Yes, all working. I just placed that command in /etc/rc.local and now the interface comes up after warm reboot. PHEW!

Which version of the UE300 is it? If you look very carefully at the label in the cavity beside the serial number, there will be a version number (e.g. "v1.0").