Say 'hello world'

How do I say 'hello world' on the internal speaker?

Could you give A LOT MORE DETAILS, please???

Because my answer at this time is: just play the audio file.

There is a program called espeak..

espeak "hello, world"

but I don't know how to address an internal speaker on OpenWrt

Alternatively, is saytime available for OpenWrt?

Maybe I need to

opkg install kmod-sound-core

I get errors similar to those described here:- this a RiPi?

Need to know the hardware, particularly the sound card.

Yes - the specs are here

It doesn't mention audio chip, but saytime works on Raspbian.

This shows what to do on Raspbian:

Does this mean you already hear audio???

If so, simply install software that will play the file.

There is no audio chip on a Pi board. The internal audio on a Pi comes by low-pass filtering a PWM output of the CPU SoC, or part of the GPU to the HDMI port, which must of course be connected to a TV or other device that decodes HDMI audio.

I don't think the drivers for either of these have been ported to OpenWrt.

USB sound cards are readily supported through the sound-core, usb-audio, etc.

1 Like

This is the only sound card. If "internal speaker" meant inside the Pi, that is not possible in the OS (in terms of playing something like an audio file).

saytime does not play a file, it simply outputs the time to the internal speaker.

As others have stated, the pi does not have an internal speaker. Why would you want to use LEDE for this anyway?

I am able to use 'espeak' or 'saytime' under Raspbian. It will output via the RCA audio jack socket to an external speaker.

I would be surprised/disappointed if LEDE was not able to do this.

I would want to do this because I could :slight_smile: - have you no imagination?

Urgent alerts or even reminders could be output using 'espeak'.... Imagine an intruder alert triggering 'espeak baddy from breaking in'....

If this currently works, you can create a script to prepare the text of the alerts from: logs, data saved in files, etc.

You can easily check the availability of a certain package via the packages table:

Unfortunately I have, so far, been unable to get 'espeak' to work because I can't figure out how to configure sound under OpenWrt on an RPi.

That is because the driver for the RPi on board 3.5mm jack has not been ported to OpenWrt. It is only in Raspian.

It should work with a USB sound card.

What is involved in porting it?

Do you have enabled the device tree overlay in /boot/config.txt?
There should be a dtparam=audio=on