Samba4 problem?

Is there something special with samba4?

The configuration is the same as with an old MT300N-V3 with kernel 4.14.151 and samba & I have no problem for reading the contents of a USB key with Windows 11

Windows Explorer see the samba4 server well
Manually with \IP\ this doesn't work either -> no access

44

With the console i have no problem for ls /mnt/sda1

default template is not modified

ls -ld /mnt/sda1

root@BELKIN-180:/# ls -ld /mnt/sda1

drwxr-xr-x 2 root root 160 Nov 11 11:44 /mnt/sda1

shouldn't be the issue, got I'd chmod 777 /mnt/sda1.

chmod 777 /mnt/sda1/* -R

no change

with the old MT300N-V2
if I not plug USB key I still see the USB sharing in Windows Explorer
sure no content !!!

with samba4 nothing

Well, its not the same as what I wrote, but OK...

MT300N-V2 run in relayd mode

i program the RT1800 in relayd mode at this time

in relay mode problem request login & password

44

Which would have a configuration of the template file which works without it being used by a specific user therefore with any user

It seemed to me that this was the default configuration.with samba3

Solved with Windows GPedit -> WorkStation Lanman ->

it would be interesting to know how we can export/import this parameter

found solution:

Create with GPedit
Copy for future folder C:\Windows\System32\GroupPolicy
After restore folder & reboot

huh ?
it's a windows setting...

​*
What I don't understand is why it works with my old MT300 & samba 3
Firmware OpenWrt Version SNAPSHOT r11365-df60a0852c / LuCI Master (git-19.304.35036-4798b3f)
Kernel Version 4.14.151

and not with the CR25Wing as well as the RT1800 Belkin
Firmware Version OpenWrt 23.05.0 r23497-6637af95aa / LuCI openwrt-23.05 branch git-23.306.39416-c86c256
Kernel Version 5.15.134

I'm really starting to wonder if all the security stuff means that the newer it is, the worse openwrt works

because samba3 <> samba4 ?

can always try ksmbd ,,,

I just tried ksmbd
Observations:
Explorer is much faster than with samba4
I still have to use gpedit for it to work like with samba4

I have real NAS: QNAP TBS453A as well as Synology DS218+ and I have never had any problems
Also good with an USB key connected to my Livebox 6

There is definitely something wrong with OpenWrt

then you can start comparing the gl.inet samba3 with openwrt samba4 settings, see if you can spot the difference.

I too have several devices completely unrelated to openwrt, where it just works.

openwrt provides a samba4 package, it doesn't maintain it, you're barking up the wrong tree, imho.
openwrt's samba4 config could be off, though.

can this be reproduced on a vanilla Linux, where you replace samba3 with samba4, or the other way around ?

These are just observations

Otherwise I have already had comments like:
If you find that it works poorly, just don't use OpenWrt!!!

Now if that doesn't bother anyone..

I just installed samba4, mapped a dir, and made sure legacy SMB 1.0 support was disabled.
no issues whatsoever.

samba4 is a resource hog, the performance (throughput) can be pretty bad, especially if multi core support isn't enabled. again, not openwrt's fault.

Question: Are you using the default samba4 configuration ?

Yes, I am.

Installed, created dir, configured share, done.

I will therefore consider that even if we can get samba4 to work ( gpedit used with windows ) that it is too slow

For ksmbd you must also use gpedit with recent versions of OpenWrt