Runtime exception No Lua runtime installed

Currently unable to login into luci I am getting the error Runtime exception No Lua runtime installed

Kind of self explanatory, innit?

1 Like

I have Luci installed could someone assist I am new to openwrt

What did you install onto your device? Do you know how to use ssh? If so, what is the output of:

ubus call system board 

There's a difference between luci and lua. Because you haven't provided yet information @psherman asked for, maybe your problem will be solved if you run the following on your router:

opkg update
opkg install luci-compat

I have SSH I installed netgear_wax202-squashfs-sysupgrade.bin](https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-netgear_wax202-squashfs-sysupgrade.bin)

You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

3 Likes

... or just sysupgrade to stable 22.03.2, it'll come with the webui.

1 Like

Could this be done via ssh

(win)scp the 22.03.2 sysupgrade image from https://openwrt.org/toh/hwdata/netgear/netgear_wax202 to the routers /tmp dir, run sysupgrade /tmp/name of sysupgrade.file in ssh.

Wget in ssh might work too, unless it's missing cert packages.

2 Likes

Thank you I appreciate it a lot I am new to this

Not sure if this fits.

1 Like

Hi.
Same here while trying to install the latest snapshot r21335 on a Netgear R6220 (mt7621).
I have tried to install luci-compat but it's getting worst. Reversed to r21313 which works fine.
Later today I'm going to try again, with lighter custom build.

why not simply use stable from https://openwrt.org/toh/netgear/r6220 ?

1 Like

One must test snapshot releases to report bugs :slight_smile:
Actually the device is used as an AP.

EDIT : same result after flashing a light custom build (default packages + luci)

Did you follow through the thread links and see the new luci-lua-runtime package reference?

May want to avoid Wed Nov 23 13:56:12 2022 snapshot for MT7621AT/7615N routers as well.

Same error displayed:

Runtime exception
No Lua runtime installed

1 Like

Hi.
Yes I'm aware of this.
After installing this package, I got this when trying to display the default homepage.
192.168.1.x/cgi-bin/luci/admin/status/overview

Unhandled exception during request dispatching
/usr/lib/lua/luci/ucodebridge.lua:23: /usr/lib/lua/luci/template.lua:158: Failed to load template 'admin_status/index'.
Error while parsing template '/usr/lib/lua/luci/view/admin_status/index.htm':
No such file or directory

In error(), file [C]
called from function [anonymous function] (/usr/lib/lua/luci/ucodebridge.lua:23)
called from function  ((tail call))

In \[anonymous function](), file /usr/share/ucode/luci/runtime.uc, line 138, byte 45:
called from function [arrow function] (/usr/share/ucode/luci/dispatcher.uc:778:70)
called from function render ([C])
called from function render_action (/usr/share/ucode/luci/dispatcher.uc:768:24)
called from function run_action (/usr/share/ucode/luci/dispatcher.uc:779:4)
called from function [anonymous function] (/usr/share/ucode/luci/dispatcher.uc:993:48)
called from anonymous function (/www/cgi-bin/luci:39:12)

`        return lcall.call(modname, method, ...args);`
Near here ----------------------------------------^

If I manually browse another page such as 192.168.1.x/cgi-bin/luci/admin/status/routes than it works.

EDIT : some buttons don't work nevertheless, such as Updates list in software.

1 Like

Already fixed... Yesterday.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.