Running OpenWrt on my Nanostation loco m5

Hello everyone,
I tried to install OpenWRT on my Nanostation loco m5. So i followed this
Guide on how to do it. The installation succeeds and the 4th signal LED is blinking on boot. But i cant SSH in or access the LuCI Webinterface. I checked my IP settings, but everything is correct. I just don’t know what to do now. Can someone maybe suggest something that i maybe missed?
(Sorry for my bad English its not my native language)

The LED should eventually stop blinking and stay on steady. This may take a minute or two on the first boot. Once fully booted, set your PC to the standard DHCP client mode (Obtain IP Address Automatically) and connect it as the only device to the Ethernet port (Disconnect PC from any other networks). The PC should obtain an address of 192.168.1.X from OpenWrt. Access the router at

If you have the XM version, lack of RAM (it has only 32 MB) may be a problem with recent OpenWrt versions.

I have the XW version, also the LED stops blinking and goes off completely. My Computer doesn’t obtain a IP over DCHP, i checked in the Settings and with ipconfig

My PC is connected straight to the POE injector, which is connected to the Nanostation

try an older version first, like 19.xx, and than upgrade. and do not keep setting

1 Like

Ok, i will try that

Nope, still didn’t work. The signal light blinks fast on startup, then slows down and goes off completely. I looked at ipconfig and my Computer still gets no ipv4 address assigned.

maybe is the version of the stock firmware that you are running? that block that?

I am running on the latest Firmware (6.3.6), and a tried to downgrade to 5.5.x, but there isn’t even a unsigned build for my Nanostation

It sounds like OpenWrt is running. I have an XW running 22.03.3, it is compatible. You're right on the later builds the last signal light goes out to work as a signal light instead of staying on.

Static IP your PC to then see if you can ping at If it instead answers pings to it's still running stock firmware.

Thanks, gonna try later

Nope, still won’t work. It doesn’t answer on both IP addresses

EDIT: i reflashed stock Firmware and it worked fine. Only after i flashed OpenWrt on it, it started to have this issue.

First off be sure you used the build with loco and XW in the name, as the builds for other Nanostations will not operate the Ethernet port properly.

I've been running OpenWrt on mine for a long time so I can't say if the factory file install process still works. But they definitely can run 22.03 once installed. Try installing 19, even an ar71xx build to get away from factory then upgrade.

The "factory" file can't be TFTP to later bootloaders that check for signed firmware, but I don't know if this model was ever subject to that. There is an alternative installation process using mtd from the CLI of the factory firmware. In that case the sysupgrade image should be flashed.

So i tried to Flash a 19.x build, but still nothing. The TFTP transfer succeeds, and the signal lights go off and on in a loop, but still i cant ssh into it, or ping it

First , after you install XW.v5.6.15-sign.31612.170908.1440.bin

1-Install openwrt-22.03.0-rc1-ath79-generic-ubnt_powerbeam-m5-xw-squashfs-factory.bin
2-Then upgrade by openwrt-22.03.0-rc1-ath79-generic-ubnt_powerbeam-m5-xw-squashfs-sysupgrade.bin