Running OpenWrt on a old mini PC but network unreachable

Hi, I've got an ancient mini PC (Koala Nano) based on Vortex86sx. After a while I was able to boot it with a live USB containing Attitude Adjustment 12.09/x86/generic (combined-ext4.img). Despite the initial success (OpenWrt is booting), the unit is not able to reach my lan network.
With BusyBox v1.19.4 I'm able to ping local Loopback but 'lan' is not available, despite /etc/config/network is configured as indicated (IP address just as example):

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fdb0:9eff:bb07::/48'

config interface 'lan'
	option type 'bridge'
    option ifname 'eth0'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option gateway ''
	option dns ''

ifconfig is reporting this:

... no lan

I've followed all the indications available in similar posts; they are essentially giving great instruction on how run OpenWrt but very few on set-up and trouble shooting. There is something I'm missing?

Thank you in advance for support

You won't get any support with AA12.09. Is there a reason you didn't use a more recent version?


Try the19.07.1 x86legacy build it may work on 486 type chips.

Then you will probably need to manually identify and install the driver for your Ethernet chip, is why no Ethernet interfaces were found.


Thank you. I will work around.
Not easy for me because I'm not skilled with Kernel's matters. The reason why I'm using an old version is that the PC is not booting with grub2.
I'll let you know of any progress.

Hadn't thought about that.

Realize the kernel code is compiled into a single file as a compressed binary blob; the bootloader's job is to extract it from the disk to memory and then jump the CPU to the start of the kernel. After that is completed, the kernel takes over all machine operation, the bootloader becomes abandoned code and its memory is reclaimed.

So it would be possible to launch a new kernel from an old bootloader merely by replacing the kernel blob file in the boot partition of the disk, but keep the rest of the bootloader old. For some historic reason this file is often called "vmlinuz" and that is the case here. This file can be downloaded individually from the official download page.

If that works-- it should boot but then crash because obviously the root file system contains the wrong files-- replace the rootfs separately as well. Download the rootfs file (I think that would be rootfs-ext4.gz), uncompress it, and dd it to the rootfs partition of the disk. Do not overwrite the whole disk just the rootfs partition.

Half a success... following your suggestion the computer is booting... unfortunately the CPU is not suitable for the 19.07 kernel.

I think it's a good start... I shall go back in archive and find a OpenWrt version with a kernel suitable for a CPU without Floating Point Unit (FPU)

Did you try legacy or generic?

None of the images will work on a system without a FPU

1 Like

I tried legacy.

yep. AA12.09 is working but no more supported. Now I'll move up from 12.09 and I'll try any following release until is possible.... just to play all the cards.

Today I spent sometime in testing many solutions and at the end I produced a live USB able to boot 18.6.1 :smiley:

Of course the Ethernet driver is not working yet but I hope somebody can indicate me a way to replace the standard with a working one.

Googling I found, in producer pages, the patch they indicated to solve the Ethernet issue:

Looking inside the code it's mentioned "RDC R6040 PCI Fast Ethernet support" that I suppose is my Ethernet chip.

Can somebody instruct me how to patch the 18.6.1 Kernel with the right driver?

Thanks in advance

hate to be a party poopers but why? you know that gl-inet devices start at $20 and are faster and better and take less power right? the cost of power alone probably makes your box more expensive after a year

I know, but it's my hobby to play with stuff like this, and about consumption it's not so bad, probably equivalent to a standard router. I'm not even sure to really use it; as you said there are devices that "are faster and better".

well that's a good reason as long as you make that choice :+1:

Hi, it seems that the driver for RDC R6040 PCI it's available, with instructions to compile it in Linux Kernel. See the following link:
Do you know if there is any available OpenWrt package including it, ready for installation in 18.6.1.repository?
Thanks and sorry for bothering you.

That's FreeBSD's manpages you're linking too, very dated btw. (current version)
Pretty sure that current versions of FreeBSD doesn't run without a FPU which seems to be confirmed here:

1 Like

I discovered that the driver for the ethernet chip exists since AA-12, it's "kmod-r6040", but once I try to add it in 18.6.1, recompiling the images with it's image generator, the kernel is not booting anymore asking for FPU.
I returned back AA-12, downloaded it's image generator from repository, added the correct "kmod-r6040" version, generated a new set of files but anything work... I should probably try to patch kernel but, provided I would have the necessary skill, I've doubt that the FPU error will appear again.... It's Catch 22. It's a pity because I was so near to revive the old crap.
I'm going to close the post, thank you to everybody who tried to help me. I learned a lot from the experience.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.