Rtl8811au wi-fi dongle, wireless is not associated

After I switched from GL.inet's custom version to an official OpenWrt snapshot img, I cannot get my wi-fi dongle to work again.

I was using the dongle with an ipk that the GL.inet folk provided : https://forum.gl-inet.com/t/adding-wi-fi-to-mv1000-brume/9610/47

My backup from the GL.inet's /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs@d0000000/d005e000.usb/usb1/1-1/1-1:1.0'
	option name '8811AU'
	option band '2G_5G'
	option ieee80211n '1'
	option disabled '0'
	option repeater '0'
	option channel '6'
	option htmode 'HT40'
	option noscan '0'
	option hwmode '11g'
	option phy 'phy0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ifname 'wlan0'
	option encryption 'psk2'
	option ssid 'Plume'
	option key 'secret'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs@d0000000/d005e000.usb/usb1/1-1/1-1:1.0'
	option disabled '1'
	option ieee80211n '1'
	option name '8811AU'
	option band '2G_5G'
	option repeater '0'
	option hwmode '11g'
	option channel 'auto'
	option htmode 'HT20'
	option country '00'
	option legacy_rates '1'
	option phy 'phy1'

Now, in place of that ipk which is made for an older kernel, I have kmod-rtl8812au-ct installed as the number is the closest to 8811au.

My current attempt at /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs@d0000000/d005e000.usb/usb1/1-1/1-1:1.0'
	option ieee80211n '1'
	option disabled '0'
	option repeater '0'
	option channel '6'
	option htmode 'HT40'
	option noscan '0'
	option band '11g'
	option phy 'phy0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '0'

Basically the 'radio0' is copied from backup, 'default_radio0' is left as-is.

In Luci, there is 'radio0' with white background at the bottom of overview:

Type: 802.11bg
Channel: -
Bitrate: -

SSID: OpenWrt
Mode: Master
Wireless is not associated

And the network drop-down menu doesn't include wireless.

I am sorry if this is a really basic mistake I am making, I have been constantly jumping around the openwrt documentation for 3 days and very confused and tired. Any help is appreciated.

Edit: I should add that the 3 days had nothing to do with wi-fi. It was just me not understanding that GL.inet had a custom version, and that as an img gets old, newer packages on opkg can't be installed onto it.

I decided to get back on the GL-inet custom image, since I really need wi-fi.

But I also do want to be on devel snapshot of mainline OpenWrt, for a certain recent package (coturn).

I am open to buying a different USB wi-fi adapter that has a more stable open driver for linux - are there any recommended products for this rather niche situation?

Suggestions to make my current dongle work on mainline OpenWrt are of course welcome too.

I think this is the package source code that the ipk came from:

How can I compile this on a snapshot build of mainline OpenWrt?


Edit. Actually, looking inside the ipk, it says

Package: kmod-8811au
Version: 4.14.151+2020-4-30-1
Depends: kernel (=4.14.151-1-ad1d2012e647da676e21f405cd1a44c7), kmod-mac80211, kmod-usb-core
Source: package/kernel/rtl8811au
SourceName: kmod-8811au
Section: kernel
Architecture: aarch64_cortex-a53
Installed-Size: 744708
Description:  Kernel modules for the Realtek 8811au  USB 802.11ac
 wireless USB adapters

and that doesn't exist on their repo.