RTL839x and support for the Zyxel GS2210 devices

I came by a GS2210-24HP which seems to be a nice candidate for OpenWRT and it seems like some of the GS1900-48 images should work on the device. Unfortunately following the instructions I'm not able to upgrade the image via the web gui. I also tried, via the convenient serial port at the front of the device, to tftpboot an image. However the device doesn't use u-boot but rather Bootbase.

I sngged the following device info:

GS2210-24HP> atsh
ZyNOS Version          : V4.50(AANE.4) | 07/08/2020 13:42:42
Bootbase Version       : V1.00 | 12/18/2013 13:22:24
Serial Number          : S152L18000290
Vendor Name            : ZyXEL
Product Model          : GS2210-24HP
ZyNOS ROM address      : b40a0000
System Type            : 8
First MAC Address      : A0E4CB8275E6
Last  MAC Address      : A0E4CB827602
MAC Address Quantity   : 29
Default Country Code   : FF
Boot Module Debug Flag : 00
CPLD Version           : N/A
RomFile Version        : 55
RomFile Checksum       : d068
ZyNOS Checksum         : 2e09
SNMP MIB level & OID   : 060102030405060708091011121314151617181920
Main Feature Bits      : C0
Other Feature Bits     :
          02 4D 00 00 00 00 00 00-00 00 00 00 00 00 00 00  
          00 00 00 00 00 00 00 00-00 13 00 00 00 00          


GS2210-24HP> atdt

Flash type = 0x0
Reboot Cnt = 0x0
Debug Flag = 0x0
DRAM size  = 0x8000000
Stack Ptr  = 0x0
IDStr      = ZyXELRTR
No Debug Information Available

My question is twofold:

  • how best to try and get test images loaded onto this?
  • has anyone got anything similar to this? I saw that @biot and @raylynnknight have worked on the GS2210 series - what's the best place to find your code on this family of devices? / what can I do to help?

Yes, the 48-port GS1900 looks like it's pretty close. Still, looking at what I can see about the GS1900-48HP vs GS2210 series, they are different enough I'm not sure I'd want to try an image for the former on the latter. That second flash in the 2210 doesn't seem to be mapped in the DTS you linked.

Thanks for your comments. And indeed I'm not imagining falshing some random image to the switch to magically work. But did find it odd that nothing happens when trying an [incorrect] image. Can anyone comment on the Bootbase vs u-boot? Is it common on the GS2210s to use Bootbase instead of u-boot?

@VA1DER what do you mean by 'second flash'?

This is probably what defines this series and makes it different from the gs1900s.

You might get some hints from https://svanheule.net/switches/zyxel_xs1930_series

But AFAIK this hasn't gone anywhere yet

I put the wrong link in my earlier post (fixed now) to the GS2210 series. If you look at it the correct link you'll see there are two flash chips in the GS2210 series. One is 16Mib, one is 64Kib. The GS1900's don't have that second chip.

It's too small to be used for much. It could be used for configuration settings. It could also be where the bootloader lives. I'd move forward very carefully with any attempts to flash a GS2210 with a firmware for a GS1900.

Thanks @VA1DER and @bmork - I'll hold off flashing any random images :slight_smile:

If there is anything I can provide from this device / dumps etc let me know.