Rtl8188 on x86


i'm new to lede and to the forum.

i installed lede on x86 computer with 3 wireless interfaces:

  1. ath9k
  2. ath9k-htc
  3. rtl88188ee

the first two work pretty well after installing package. but i cant find the drive for rtl8188ee in any of lede package.
the card does work in any other linux i tried (arch, ubuntu)

please help
thanks in advance

if it's in the mainline kernel you can try enabling it using make kernel_menuconfig

thank you so much for the quick answer.
sorry for my ignorance, does it mean i have to install openwrt build system and build openwrt from source?

yes, but, did you tried the kmod-rtl8xxxu driver package ?

yes i did, well, i think i did. I didnt fully understand if this package is like any other package where i just install and the card appears when i ip list

again your help is greatly appreciated

edit: i meant ip link ofc, i'm to tired for this

i invested another 8 hours from my life (i'm very old and slow) and followed build system (very good step by step instructions btw) and installed build system.

but now when i run make kernel_menuconfig CONFIG_TARGET=x86_64 i cant find rtl/realtek under any of the options in the menu (checked under wireless, and checked under drivers and in fact i tried to check under any of the option presented in that menu)

any help will be greatly appreciated.
thanks in advance



I do not see EE, only: CE, CU, DE and RU.

thanks for the quick answer.

yeah, there is no package for it, that's my problem.
but it's mainline: https://wireless.wiki.kernel.org/en/users/Drivers/rtl819x like lucize said, and i'm trying to enable it using kernel_menuconfig