RT3200 issues after attempting to upgrade snapshot

Hi all, after trying to make some changes to my openwrt install on my RT3200 it seems I've mucked things up a bit. A few months ago I followed the directions on https://github.com/dangowrt/owrt-ubi-installer and everything seemed to go okay:

However now after trying to add support for an external usb drive things have gone a little bad.

First when I tried to install some of the usb plugins needed for my interface via the web interface it was reported my kernel was not compatible
IMAGE: https://forum.openwrt.org/uploads/default/original/3X/3/f/3f9a438c57b8d565c04b9413a043974ff8d7f6b7.png

Also when using the update list option one of the packages fails to fetch:
IMAGE: https://forum.openwrt.org/uploads/default/original/3X/b/6/b6eec902097c4a88cdf7ef9fb48770fc6a1b2688.png

Based on responses I found around the forum it seemed the best course of action would be to upgrade to the latest snapshot the router supported, and I had trouble determining exactly that was. I ended up installing the linksys_e8450-ubi-squashfs-sysupgrade.itb file from https://downloads.openwrt.org/releases/22.03.0-rc1/targets/mediatek/mt7622/ but after that install in addition to still having the same kernel mismatch, my 5ghz radio doesn't seem to work anymore. I tried reverting back to the release I originally used from https://github.com/dangowrt/owrt-ubi-installer/releases but the 5ghz still doesn't seem to work. Also, when using the attended upgrade option, I get another error:
IMAGE: https://forum.openwrt.org/uploads/default/original/3X/d/3/d3eb95d8cfbd4fa08e55178eee04b18d7f303daa.png

Apologies if this issue has been covered already in the forum, however I haven't been able to apply any of the given solutions correctly yet. Many thanks for any advice or ideas anyone can send my way.

If you used the old installer that doesn't update the ECC format of the factory partition, using a new build the 5 GHz radio will stop working because the factory partition is in the old format which is now not readable by new kernels. The fix for this is to run the installer again using the new version of the installer.

This model is supported in 22.03 release builds. I would use the 22.03 release build unless you really need something that is only in snapshots.

1 Like

Thanks so much for the advice. Just to confirm I should use the file marked mediatek-mt7622-linksys_e8450-ubi-initramfs-recovery-installer.itb from https://github.com/dangowrt/owrt-ubi-installer/releases ?

If you're already running openwrt, download and flash the sysupgrade image.

https://downloads.openwrt.org/releases/22.03.0/targets/mediatek/mt7622/

Thanks so much for the suggestion, I tried flashing linksys_e8450-ubi-squashfs-sysupgrade.itb but it seems like all the aforementioned problems persist.

Did you reset the settings in the process?

I uncheck the save settings checkbox whenever flashing images, so I think that's right, the settings should be getting reset

Ok, assuming the flash went well, try https://openwrt.org/docs/guide-user/storage/usb-drives to get your storage up and running.

Or you actually need to redo the initial flash, as @mk24 suggested.

Ok, to confirm that means I need to flash the file marked ubi-initramfs-recovery-installer.itb
from https://github.com/dangowrt/owrt-ubi-installer/releases ?

Thanks guys, looks like I've got it figured out. First I booted into recovery mode by holding the reset button while turning the router on, then I first installed ubi-initramfs-recovery-installer.itb
from the github, followed by the squashfs-sysupgrade file. Looks like everything is now working smoothly.

1 Like