RT-N56U B1 installation through TFTP not working


I am trying to follow the instruction about how to install openwrt to my asus RT-N56U B1 but the tftp command in the wiki isn't recognized by windows, ( tftp -4 -v -m binary -c put )

So I tried to send the binary with the normal tftp -i command and while it has sent the firmware, the router power led just blink fast after the flashing process, wifi led aren't on and I can't access to the router through ssh.

How can I solve this problem?

I flashed this device recently. I am not very familiar with Windows though. I used these commands:

put filename.bin

If you had fast blinking of the power led, most likely Openwrt is installed. And also disabled Wi-Fi tells the same.
Wi-Fi is disabled in Openwrt by default. You should connect with a cable to enable it.

Okay but what do I do? Like I connected my computer to the WAN port of the router and tried to SSH into the router with in order to try to access the config of the router but the connection was denied.

How can I setup my router from there?

Also I have only one ethernet cable, so I can't connect both my modem to router and pc to router at the same time

First of all you should connect to LAN port of the router.

You need only one cable to connect your PC to the router and configure Wi-Fi.

Ok it's in the LAN port, what's the next step?

If the interface in you pc is set to DHCP, then it should get an IP from the router and you'll be able to login into Luci GUI using any browser, or ssh to root@

I have set "obtaining automatically an IP address" on the windows setting so DHCP should be set,

Trying to log in luci GUI or ssh to fails as it says no route to host with PuTTY, and the web server is inaccessible

Well, then maybe it was not flashed properly. Try again, don't forget "binary".

Did the PC get an IP?

I hve tried again, -i argument stands for binary mode.

Same result

My PC IP is with mask

I think it's not on the same network as the router for some reason?

Did you set a static IP before trying to flash?

As mentioned by the guide I set my PC to

It is still not clear to me. This is the manual:

  • Set your computer's IP-Address to

  • Power up the router with the reset button pressed.

  • Release the reset button after 5 seconds and power LED blinking.

  • Upload OpenWrt sysupgrade image via TFTP:

Are you trying to flash using a cable connected to a LAN port? Before it was very unclear.
What happens after you run the tftp command? should be OK after the flashing process. Wait for some time and try to connect.

What I have done.

Set ip to

Ethernet cable in WAN

Set router to recovery mode, with led slowly blinking,

tftp binary mode the kernel openwrt

Then says file sent completely

Transfer complete all leds are shut down

Router boots, then led flash fast

I put my ethernet cable on LAN this time, and set "get IP automatically"

Try to connect to

Why cable to WAN?

This is wrong. You need to flash sysupgrade.

In order to flash the router? That's how I've done to flash padavan CFW before

Really? but in the guide it's mentioned that I need to flash first the kernel, then the sysupgrade through ssh or web client

Maybe it is possible through WAN too. I used LAN. So flash sysupgrade.

Where did you find it?

OpenWrt Firmware Selector

It gives me kernel and sysupgrade, with additional note about kernel : Useful for a first installation

Then sysupgrade mention : Sysupgrade image are supposed to be flashed to router with openwrt already installed