RT-AC57U installation

do you know what i'm wrong? ( -i ) not found

Σχόλιο 2020-04-05 205408

The command syntax doesn't seem right. I know that you used what's in the Wiki, but it appears that it needs to be corrected.

I imagine the intended syntax was supposed to be

mtd -write /tmp/owrt.bin -d linux

Though, as mtd can do damage if done incorrectly, please wait for confirmation form someone who knows Linux.

Edit: I take that back. It appears that Asus actually include mtd-write, and that the syntax you entered is correct for Asus firmware.

Though, can you confirm that your router is running Asus firmware and not a third-party firmware?

Are you using AsusWrt firmware, and does /tmp/owrt.bin file exist ?

If you are not using AsusWrt, you should restore original AsusWrt firmware using Asus Firmware Restoration tool for Windows imho.

Run third-party firmware with dual wan and vpn, maybe this is problem. And connect with wifi not cable . The file exist in router

Type the following to see if the command is supported


as you can see i've also transferred the file . in powershell i get this

A command that returns nothing is by default, in a UNIX shell, a command that ran successfully.

Your second mtd-write -i attempt seems to have worked just fine. Did you follow the rest of the instructions on the wiki, if any?

I follow the instructions but nothing changes, I don't know what I'm doing wrong, do I put a specific ip address on the adapter? but if it were so I could not log in. Is the file not correct?

I notice WinSCP shows you transferred openwrt-19.07****.bin to the root of router.

It should be transferred to /tmp folder, and renamed to owrt.bin before executing

mtd-write -i /tmp/owrt.bin -d linux


(I think the above mtd-write command takes 30 seconds to execute on RT-AC57U before prompt returns)

What firmware is currently installed as you previously mentioned using third-party firmware? (eg. AsusSrcMod or Padavan) Has anyone considered the mtd-write command may not work properly in this third-party firmware?

Ensure you are using original AsusWRT OEM firmware before installing OpenWrt.
eg. use Asus Restoration tool for Windows as described in the RT-AC57U openwrt wiki page to return to original firmware.

1 Like

I also renamed the file to owrt.bin and added it to the temp folder on the router. I have also restored to the router using the asus restoration tool with stock firmware. I'll try to do it all again this afternoon while I work and I'll tell you.when I give this , mtd-write -i /tmp/owrt.bin -d linux , I get the admin@(none). Is this correct , you see in the photo

I notice you did not execute 'reboot' command in your uploaded image?

fyi, I had padavan installed on my RT-AC57U as I use it as a 5 GHz wireless bridge.

I used Asus Restoration tool to restore Asus OEM firmware Version .
Created new 'admin' account with password. Enabled SSH.

I use WinSCP to copy owrt.bin to /tmp folder.

I normally use PuTTY, but this time I used Powershell to SSH into Asus

The mtd-write command was completed in 30 seconds.

I tried to ssh into Asus with OpenWrt but it failed as you can see in above image and I don't have patience to fix this issue.

I reverted to using trusted PuTTY to SSH into

Web browser brings up LuCI on too.

My RT-AC57U v1 is H/W version A according to label underneath router.

1 Like

I did it, the problem was that I was going into powershell as an administrator and not as a simple user.
I saw it on the photos from the powershell listed by the friend above, thanks for the help, and if I want anything else I can ask?

Please mark thread as 'Solved'.

sorry where is this?

Try looking near the 'Reply' button for the post which solved the problem. (3 dots?)

ok i marked solution

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.