Rpi4 get exactly 94 Mbps, every speed test

I'm new to openwrt and new to using Rpi4 as a router. I like openwrt much better than ddwrt - should have made the switch a long time ago. anyway, I've managed to install openwrt and get the wireless and ethernet interfaces up and working. I can connect to wan (on eth0) by connecting to wlan0 and eth1. When I run speed test with ethernet directly to modem, I'm getting 750 Mbps. When I hook ethernet to Rpi4 eth1 and run speed test, 94 Mbps every single time... exactly. Same when connecting to wlan0, 94 Mbps. eth0 goes directly to modem. eth1 has a usb ethernet adapter.

I've enabled Software Flow Offloading (and Hardware Offloading, although I doubt it is supported but it doesn't change test), packet steering, irqbalance (and enabled in config to '1'). I've also overclocked Rpi4 to 2000 and set over_voltage to 6, also put gpu_freq to 750. And rebooted.

wan -> eth0 (dhcp client, ignore dhcp server, in wan firewall zone)
lan -> br-lan (static ip, in lan firewall zone)
eth1 -> eth1 (unmanaged, act as dhcp server, in lan firewall zone)

br-lan -> eth1 (bridge ports eth1)

then wireless wlan0 interfaced with lan and eth1.

Not sure if this is the way to do it, but it is working other than limiting speed. I'd love to get this speed thing worked out so I can set up the wireguard vpn client and figure out how to get other ethernet clients to show up with my switch connected to usb ethernet adapter.

Thanks for any help!

Are you using the same ethernet cable for all your testing?


Well, that was an easy fix. I've got a bunch of ethernets and I guess I picked a bad one to connect from Rpi4 to modem. A different ethernet is giving 650 Mbps. So things are getting better. Thanks

ps. switch didn't need any configuration when I hooked a second computer up to it. wireguard, here I come.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.