Rpi4 < $(community_build)

thank you! I installed it using your instructions and this youtube video


whats the luci version on it? it is little bit slower compared to the one install after flashing image. And how i can change it to that version of luci? I think the default one
1 Like

manually... go to SYSTEM>System>Language and Style

you will have to repeat that if you update unless you create edit the /root/wrt.ini file and include it in your sysupgrade.conf

LUCIDEFAULTTHEME="bootstrap"
ENABLEDSERVICES="banip adblock sqm https-dns-proxy"

there is not a huge need to update more than once every few weeks / month now that the build has stabilised a little... unless some new core code changes. so manually in your case would be just fine :sunglasses: ( and you'd need to go to SYSTEM>Startup to ENABLE your https-dns-proxy etc. and/or disable maybe things you don't need )

1 Like

your probably referring to the lovely ARGON THEME @jerryk [thankyou]

i'm finding it just as quick if not quicker than bootstrap surprisingly
(as always I recommend the also lovely browser plugin 'darkreader')

1 Like

r14001-9950bc92e3
new 14001 build is out?

I think master is currently r14009... If you build the image yourself you could have a new update daily it seems, how much actually changes I'm not sure, I just recompiled my image after 14 days uptime just to try out the settings back up procedure, so now when I flash a new image to the SDcard it's already loaded with all my set up, so acts like it's just been rebooted... Moving from a R7800 to the pi has been much easier than I expected.

1 Like

can someone please tell me why adblock is not working on my pi4? is it becuase of dns over https?

[root@network /]# /etc/init.d/adblock status
::: no adblock runtime information available
[root@network /]# /etc/init.d/adblock resume
[root@network /]# /etc/init.d/adblock status
::: no adblock runtime information available
[root@network /]# /etc/init.d/adblock restart
[root@network /]# /etc/init.d/adblock status
::: no adblock runtime information available
[root@network /]#

uci show adblock | grep enabled
/etc/init.d/adblock enabled; echo $?
/etc/init.d/adblock running; echo $?

https://forum.openwrt.org/t/adblock-and-dns-over-https/70927

then what you recommend use dns over https or tls or just use simple DNS from ISP for ad blocking?

that's like asking if the freeway or back-streets are safer...

subjective-two-weavels

( that said... vpn/vps would be my preferred weavel )

1 Like

I have one more issue after updating pi4 with your image, My IPTV is not working today i turned on tv and no signal but i can access internet on tvbox
this is solution which worked for me before
settings are same but still not working

did you install igmpproxy?

the only 'pi' deviation from that guide is you'll probably need to change 'eth0.2' to 'eth1.2' ( or maybe eth1 ... )

1 Like

Oh i feel so stupid now thanks it started working as i clicked install igmpproxy in LUCI and suddenly it started working thank you again :joy:

1 Like

Thank you so much! I feel like I'm getting closer to my end goal. Now if ltefix.com would ever start back up so I could buy my LTE modem and USB enclosure...

Anyway, two questions:

  1. Any idea how to get the PoE hat fan powered up?
  2. When I try to install perl, it can't get libc. Any idea how to get around that?
1 Like
  1. In the other thread I tried to help with that but as I don't have one you really need it working / understood on raspbian before attempting it on openwrt.
  2. Works fine for me...
grep BUILD_ID /etc/os-release

Since this is eventually going into an outdoor enclosure, I'll probably just take the simple solution of moving the fan's power leads directly to the 5V supply.

BUILD_ID="r14023-1deaf695ec"

1 Like

did you do; 'opkg update'...? 'opkg install perl' works fine for me... same release

Summary
#cat /etc/opkg/customfeeds.conf
src/gz git_core https://github.com/wulfy23/rpi4-opkg/raw/master/r14023-1deaf695ec/core
src/gz git_base https://github.com/wulfy23/rpi4-opkg/raw/master/r14023-1deaf695ec/base
src/gz git_luci https://github.com/wulfy23/rpi4-opkg/raw/master/r14023-1deaf695ec/luci

Any chance you used NORCCUSTOM=1? ( edit: NOOPKGSNAPSHOTFIX=1 would also effect the opkg .conf results )

No to NORCCUSTOM=1

Let me re-write the sdcard and start over.

no worries... as a bonus latest build has persistent nlbwmon + statistics ( with conntrack and irq )

I'm having strange persistence problems. My RPi remembers things it should be forgetting. I pulled the sdcard and wrote your latest image to it. When I booted the RPi, it remembered the previous IP address I'd set on the ethernet interface.

Can't do an opkg update.
Collected errors:

  • opkg_conf_parse_file: Failed to open /etc/opkg/customfeeds.conf: Stale file handle.

I put the sdcard back in the computer, used disk manager to format the first partition (not a fast format, so presumably all blocks in the first partition were wiped). Deleted all the partitions, then wrote the image with win32diskimager.

Same results.

Do I need to somehow zero out the whole sdcard before writing images to it?

Does the RPi have some sort of built-in nonvolatile storage OpenWRT is using?

the last time I used factory... I ended up zero-ing the sdcard... ( linux dd zero + zcat dd )... not sure if win32diskimager zero's properly... just deleting is likely not enough...

the pi4's nv storage is a minimal bootloader only...( nothing os related ) previous pi's had no nv at all.