Rpi4 < $(community_build)

what is this error my internet was disconnected
and working again after restarting the wan interface

i am getting this for few days
internet stops working at night
I am unable to access router and modem and openwrt too
I thought issue with the power supply of switch, and i have already changed it
internet disconnected and i have to restart my switch, my router and pi too
I thought some issue with them or it is a issue with openwrt?

Thu Nov 26 21:57:21 2020 daemon.err insmod: module is already loaded - pppox
 Thu Nov 26 21:57:21 2020 daemon.err insmod: module is already loaded - pppoe
 Thu Nov 26 21:57:21 2020 daemon.warn pppd[14637]: Connected to ************ via interface eth1
1 Like

dont have ppp so cant really offer much... other than another user had ppp issues and mentioned using another device had no problems... so probably build/openwrt related... but your issue may be totally different.... best thing to do is;

  • test with another device or separate sdcard with bare minimum settings ( new factory )... or official-master if downloadable...
  • if it's only surface in the last few days / week... mostly likely is build or your settings/services within the build

I'm honored you'd share my Frankenrouter, but calling it a work of art is a bit of a stretch.

1 Like

mine was IPv6 related, and stable since removing ipv6...

1 Like

yes in the last few days
happened 3 times i think

can i install this package on my own? For DSL stats in the openwrt
@wulfy23 can you please tell me how to do it? If it is possible

Thank you, :hugs:

you'd need to follow up in another thread as it's not specific to the build... these things are modem specific and typically require low level skills to implement...

2 Likes

Any chance of adding SNORT into the build ?

TIA

needs working auto-setup/update scripts and a stable release due to dependencies... it does push the hardware to it's limits... so i'm not sure how many people would run it realworld... especially without a reactive / firewall integration element...

1 Like

wifi 5G working with latest release ?

  • 5g has always worked to a limited extent... ( for me anyway )...
  • around 3-5 weeks ago I perceived something was 'better'... but I have no way to quantify that really... ( likely the several patches to hostapd / mac80211 / proto etc... over the last month and a half so )

so it's worth trying again... but who knows...

all the build specific wifi 'fundamentals (underlying binaries/libraries)' are default now... so you'd likely get more feedback in a general forum thread about this...

I tested but not working ,does it possible how it working for you and what setting you do to working ?

all discussed 1/4 - 1/3 the way down this thread...

the two key issues are limited channels / modes and country selection... ( there was a third with proto init / device state hangup on settings change that required manual re-init commands... this is what I think has likely been improved most via the recent patches )

basically keep minimising / de-tuning everything... and knowing your DFS / country channels a little... with an optional first country select via raspbian / openwrt + specific iw command...

i'm not in your country... so I can't really speak for what settings will work for you...

but this really belongs in it's own thread... so please start a new one for broader assistance with this...

when new build is coming?

1 Like

i'm building often... it's a fine line between;

  • getting anything new such as package updates ( mwan, openvpn is another recent one )... bug fixes...
  • avoiding possible bugs

so I only really 'push' something that is not labelled 'beta/testing' ( which is something i'll run at home for a while to test ) when;

  • the tree looks pretty clean / there a some good benefits / it's been a long time ( 1+ months without a build 'refresh' )...
  • the 'custom build' features have bugfixes or new features... in these cases i'll often push a 'rebuild' of a known 'ok'/previous build... but not always...
  • new packages are added to the build package selection/s

at present... there is alot of work in the tree... so there is very little benefit for alot of risk...

was there something new that's been pushed that you need?

2 Likes

no i was just checking :slightly_smiling_face:

on the top of status page now it says update unavailable
and simple ad block is giving some error of unable to download list

1 Like

i'm glad you checked because it would be good to give some warning / get some consensus / strategies on how we all should handle the likely soon to be update to openvpn (2.5)... ( ref1 )

edit: i reread the commit and it doesn't seem as problematic as I first thought... likely only the script issues in the ref above or incompatible / missing ciphers on servers which probably wouldn't be too common...

most likely to effect users connecting to third party vpn servers pre-2.4 ( thus you have no control over serveropts )... or incompatible ciphers...

this is also relevant below @ r15199 ...

i'll make a build available within 24hrs... ( probably wise to remove the effected builds too )

( i'll be removing the opkg-repos for all prev builds also to encourage updating... I don't think many of you are really using them much so that should not be too much of an issue )

openssl vulnerability pre r15199
Revision	882ca13d923796438fd06badeb00dc95b7eb1467
Comments
openssl: update to 1.1.1i
Fixes: CVE-2020-1971, defined as high severity, summarized as:
NULL pointer deref in GENERAL_NAME_cmp function can lead to a DOS
attack.

DETAILS

1 Like

i updated to current build.
neither this

ssh root@192.168.1.2 sysupgrade -R /tmp/latest.tar.gz

nor this

worked.

i install manually the packages using these commands

1 Like

or

sysupgrade -R /tmp/realimagename.img.gz

just used them... and they worked fine for me... thanks for letting me know... guess well have to wait for more feedback to find out if it's something specific on my side or yours...

is there anything in

cat /autorestore.sh

?

this is also useful... to see what happened in dmesg

dmesg | grep -E '(99\-tap|restorepackages|checkinternet)'

( or LUCI > status > kernellog [from 99-kickit] onwards... )