Rpi4 and NetGear A6210 (MT7612U) - long distance problem

Hi everyone,

I'm using a RPi since month as a router with openwrt.
I was looking for a cheap but good-enough USB wifi dongle to replace the embed wifi limited to 8 devices.

I bough a netgear A6210 (mt7612u driver). It work great with one exception.

As soon as I am at 15m (~50 feets) away from the router, my devices disconnect instantly without any reason, the quality connection is good (like 4/5 before disconnect)

Here's the disconnect/reconnect log (going away, going back) nothing suspicious I think

Sat Nov  7 16:45:32 2020 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED ea:3e:42:d4:a5:7e
Sat Nov  7 16:45:37 2020 daemon.info hostapd: wlan0: STA ea:3e:42:d4:a5:7e IEEE 802.11: authenticated
Sat Nov  7 16:45:37 2020 daemon.info hostapd: wlan0: STA ea:3e:42:d4:a5:7e IEEE 802.11: associated (aid 7)
Sat Nov  7 16:45:37 2020 daemon.notice hostapd: wlan0: AP-STA-CONNECTED ea:3e:42:d4:a5:7e
Sat Nov  7 16:45:37 2020 daemon.info hostapd: wlan0: STA ea:3e:42:d4:a5:7e WPA: pairwise key handshake completed (RSN)
Sat Nov  7 16:45:37 2020 daemon.info dnsmasq-dhcp[3617]: DHCPDISCOVER(wlan0) ea:3e:42:d4:a5:7e
Sat Nov  7 16:45:37 2020 daemon.info dnsmasq-dhcp[3617]: DHCPOFFER(wlan0) 192.168.3.123 ea:3e:42:d4:a5:7e
Sat Nov  7 16:45:37 2020 daemon.info dnsmasq-dhcp[3617]: DHCPREQUEST(wlan0) 192.168.3.123 ea:3e:42:d4:a5:7e
Sat Nov  7 16:45:37 2020 daemon.info dnsmasq-dhcp[3617]: DHCPACK(wlan0) 192.168.3.123 ea:3e:42:d4:a5:7e

Here's my config

package adblock

config adblock 'global'
	option adb_safesearch '0'
	option adb_dnsfilereset '0'
	option adb_mail '0'
	option adb_backup '1'
	option adb_maxqueue '4'
	option adb_dns 'dnsmasq'
	option adb_fetchutil 'uclient-fetch'
	option adb_repiface 'wlan0'
	option adb_report '1'
	option adb_forcedns '1'
	option adb_trigger 'lan'
	option adb_debug '1'
	option adb_enabled '1'
	list adb_sources 'adaway'
	list adb_sources 'smarttv'
	list adb_sources 'winspy'
	option adb_backupdir '/tmp'

package adblock-opkg

config adblock 'global'
	option adb_enabled '1'
	option adb_debug '0'
	option adb_forcedns '0'
	option adb_safesearch '0'
	option adb_dnsfilereset '0'
	option adb_mail '0'
	option adb_report '0'
	option adb_backup '1'
	option adb_maxqueue '4'
	list adb_sources 'adaway'
	list adb_sources 'adguard'
	list adb_sources 'disconnect'
	list adb_sources 'yoyo'

package argon

config global
	option primary '#5e72e4'
	option dark_primary '#483d8b'
	option blur '10'
	option blur_dark '10'
	option transparency '0.5'
	option transparency_dark '0.5'
	option save 'Save Changes'
	option mode 'dark'

package collectd

config globals 'globals'
	option alt_config_file '/etc/collectd.conf'

package collectd-opkg

config globals 'globals'
	option alt_config_file '/etc/collectd.conf'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'wlan'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'wlan'
	option force '1'

config dhcp 'WLAN'
	option interface 'WLAN'
	option leasetime '12h'
	option start '5'
	option limit '94'

config dhcp 'WLAN_USB'
	option interface 'WLAN_USB'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '1'

config dhcp 'WLAN_EMBED'
	option interface 'WLAN_EMBED'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option force '1'

package dropbear

config dropbear
	option PasswordAuth 'on'
	option RootPasswordAuth 'on'
	option Port '22'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'WLAN_USB WLAN_EMBED'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 lan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config redirect 'adblock_dns_53'
	option name 'Adblock DNS, port 53'
	option src 'lan'
	option proto 'tcp udp'
	option src_dport '53'
	option dest_port '53'
	option target 'DNAT'

config redirect 'adblock_dns_853'
	option name 'Adblock DNS, port 853'
	option src 'lan'
	option proto 'tcp udp'
	option src_dport '853'
	option dest_port '853'
	option target 'DNAT'

config redirect 'adblock_dns_5353'
	option name 'Adblock DNS, port 5353'
	option src 'lan'
	option proto 'tcp udp'
	option src_dport '5353'
	option dest_port '5353'
	option target 'DNAT'

config redirect
	option target 'DNAT'
	option name 'ssh'
	option src 'wan'
	option src_dport '2222'
	option dest 'lan'
	option dest_ip '192.168.2.216'
	option dest_port '22'

config redirect
	option target 'DNAT'
	option name 'web'
	option src 'wan'
	option dest 'lan'
	option dest_ip '192.168.2.216'
	option dest_port '80'
	option src_dport '880'

config redirect
	option target 'DNAT'
	option name 'web secure'
	option src 'wan'
	option dest 'lan'
	option dest_ip '192.168.2.216'
	option dest_port '443'
	option src_dport '4443'

package luci

config core 'main'
	option lang 'auto'
	option resourcebase '/luci-static/resources'
	option ubuspath '/ubus/'
	option mediaurlbase '/luci-static/argon'

config extern 'flash_keep'
	option uci '/etc/config/'
	option dropbear '/etc/dropbear/'
	option openvpn '/etc/openvpn/'
	option passwd '/etc/passwd'
	option opkg '/etc/opkg.conf'
	option firewall '/etc/firewall.user'
	option uploads '/lib/uci/upload/'

config internal 'languages'

config internal 'sauth'
	option sessionpath '/tmp/luci-sessions'
	option sessiontime '3600'

config internal 'ccache'
	option enable '1'

config internal 'themes'
	option Material '/luci-static/material'
	option Bootstrap '/luci-static/bootstrap'
	option Argon '/luci-static/argon'

config internal 'apply'
	option rollback '90'
	option holdoff '4'
	option timeout '5'
	option display '1.5'

config internal 'diag'
	option dns 'openwrt.org'
	option ping 'openwrt.org'
	option route 'openwrt.org'

package luci-opkg

config core 'main'
	option lang 'auto'
	option mediaurlbase '/luci-static/bootstrap'
	option resourcebase '/luci-static/resources'
	option ubuspath '/ubus/'

config extern 'flash_keep'
	option uci '/etc/config/'
	option dropbear '/etc/dropbear/'
	option openvpn '/etc/openvpn/'
	option passwd '/etc/passwd'
	option opkg '/etc/opkg.conf'
	option firewall '/etc/firewall.user'
	option uploads '/lib/uci/upload/'

config internal 'languages'

config internal 'sauth'
	option sessionpath '/tmp/luci-sessions'
	option sessiontime '3600'

config internal 'ccache'
	option enable '1'

config internal 'themes'

config internal 'apply'
	option rollback '90'
	option holdoff '4'
	option timeout '5'
	option display '1.5'

package luci_statistics

config statistics 'collectd'
	option BaseDir '/var/run/collectd'
	option Include '/etc/collectd/conf.d'
	option PIDFile '/var/run/collectd.pid'
	option PluginDir '/usr/lib/collectd'
	option TypesDB '/usr/share/collectd/types.db'
	option Interval '30'
	option ReadThreads '2'
	option FQDNLookup '1'

config statistics 'rrdtool'
	option default_timespan '1hour'
	option image_width '600'
	option image_path '/tmp/rrdimg'

config statistics 'collectd_rrdtool'
	option enable '1'
	option RRARows '100'
	option RRASingle '1'
	option DataDir '/overlay/rrd'
	list RRATimespans '1hour'
	list RRATimespans '1day'
	list RRATimespans '1week'
	list RRATimespans '1month'

config statistics 'collectd_csv'
	option enable '1'
	option DataDir '/tmp/csv'

config statistics 'collectd_email'
	option enable '0'
	option SocketFile '/var/run/collectd/email.sock'
	option SocketGroup 'nogroup'

config statistics 'collectd_logfile'
	option enable '0'
	option LogLevel 'notice'
	option File '/var/log/collectd.log'
	option Timestamp '1'

config statistics 'collectd_network'

config statistics 'collectd_unixsock'
	option enable '0'
	option SocketFile '/var/run/collectd/query.sock'
	option SocketGroup 'nogroup'

config statistics 'collectd_apcups'
	option enable '0'
	option Host 'localhost'
	option Port '3551'

config statistics 'collectd_conntrack'
	option enable '0'

config statistics 'collectd_contextswitch'
	option enable '0'

config statistics 'collectd_cpu'
	option ReportByState '1'
	option ReportByCpu '0'

config statistics 'collectd_cpufreq'
	option enable '0'

config statistics 'collectd_curl'
	option enable '0'

config statistics 'collectd_df'
	option enable '0'
	option Devices '/dev/mtdblock/4'
	option MountPoints '/jffs'
	option FSTypes 'tmpfs'
	option IgnoreSelected '0'

config statistics 'collectd_disk'
	option enable '0'
	option Disks 'hda1 hdb'
	option IgnoreSelected '0'

config statistics 'collectd_dns'
	option enable '0'
	option Interfaces 'br-lan'
	option IgnoreSources '127.0.0.1'

config statistics 'collectd_entropy'
	option enable '0'

config statistics 'collectd_exec'
	option enable '0'

config statistics 'collectd_interface'
	option enable '1'
	list Interfaces 'eth0'
	list Interfaces 'wlan0'

config statistics 'collectd_iptables'
	option enable '0'

config collectd_iptables_match
	option table 'nat'
	option chain 'luci_fw_postrouting'
	option target 'MASQUERADE'
	option source '192.168.1.0/24'
	option outputif 'br-ff'
	option name 'LAN-Clients traffic'

config collectd_iptables_match
	option chain 'luci_fw_postrouting'
	option table 'nat'
	option target 'MASQUERADE'
	option source '10.61.230.0/24'
	option outputif 'br-ff'
	option name 'WLAN-Clients traffic'

config statistics 'collectd_irq'
	option enable '0'
	option Irqs '2 3 4 7'

config statistics 'collectd_iwinfo'
	option enable '1'
	list Interfaces 'wlan0'

config statistics 'collectd_load'
	option enable '1'

config statistics 'collectd_memory'
	option enable '1'

config statistics 'collectd_netlink'
	option enable '0'
	option IgnoreSelected '0'
	option VerboseInterfaces 'br-lan'
	option QDiscs 'br-lan'

config statistics 'collectd_nut'
	option enable '0'
	list UPS 'myupsname'

config statistics 'collectd_olsrd'
	option enable '0'
	option Port '2006'
	option Host '127.0.0.1'

config statistics 'collectd_ping'
	option TTL '127'
	option enable '1'
	option AddressFamily 'ipv4'
	option Interval '5'
	list Hosts '8.8.8.8'

config statistics 'collectd_processes'
	option enable '0'
	option Processes 'uhttpd dnsmasq dropbear'

config statistics 'collectd_sensors'
	option enable '0'

config statistics 'collectd_splash_leases'
	option enable '0'

config statistics 'collectd_tcpconns'
	option enable '0'
	option ListeningPorts '0'
	option LocalPorts '22 80'

config statistics 'collectd_thermal'
	option enable '1'

config statistics 'collectd_uptime'
	option enable '0'

config statistics 'collectd_openvpn'

config statistics 'collectd_syslog'

package luci_statistics-opkg

config statistics 'collectd'
	option BaseDir '/var/run/collectd'
	option Include '/etc/collectd/conf.d'
	option PIDFile '/var/run/collectd.pid'
	option PluginDir '/usr/lib/collectd'
	option TypesDB '/usr/share/collectd/types.db'
	option Interval '30'
	option ReadThreads '2'

config statistics 'rrdtool'
	option default_timespan '1hour'
	option image_width '600'
	option image_path '/tmp/rrdimg'

config statistics 'collectd_rrdtool'
	option enable '1'
	option DataDir '/tmp/rrd'
	option RRARows '144'
	option RRASingle '1'
	option RRATimespans '1hour 1day 1week 1month 1year'

config statistics 'collectd_csv'
	option enable '0'
	option StoreRates '0'
	option DataDir '/tmp'

config statistics 'collectd_email'
	option enable '0'
	option SocketFile '/var/run/collectd/email.sock'
	option SocketGroup 'nogroup'

config statistics 'collectd_logfile'
	option enable '0'
	option LogLevel 'notice'
	option File '/var/log/collectd.log'
	option Timestamp '1'

config statistics 'collectd_network'
	option enable '0'

config statistics 'collectd_syslog'
	option enable '0'
	option LogLevel 'warning'
	option NotifyLevel 'WARNING'

config statistics 'collectd_unixsock'
	option enable '0'
	option SocketFile '/var/run/collectd/query.sock'
	option SocketGroup 'nogroup'

config statistics 'collectd_apcups'
	option enable '0'
	option Host 'localhost'
	option Port '3551'

config statistics 'collectd_conntrack'
	option enable '0'

config statistics 'collectd_contextswitch'
	option enable '0'

config statistics 'collectd_cpu'
	option enable '1'

config statistics 'collectd_cpufreq'
	option enable '0'

config statistics 'collectd_curl'
	option enable '0'

config statistics 'collectd_df'
	option enable '0'
	option Devices '/dev/mtdblock/4'
	option MountPoints '/jffs'
	option FSTypes 'tmpfs'
	option IgnoreSelected '0'
	option ValuesPercentage '0'

config statistics 'collectd_disk'
	option enable '0'
	option Disks 'hda1 hdb'
	option IgnoreSelected '0'

config statistics 'collectd_dns'
	option enable '0'
	option Interfaces 'br-lan'
	option IgnoreSources '127.0.0.1'

config statistics 'collectd_entropy'
	option enable '0'

config statistics 'collectd_exec'
	option enable '0'

config statistics 'collectd_interface'
	option enable '1'
	option Interfaces 'br-lan'
	option IgnoreSelected '0'

config statistics 'collectd_iptables'
	option enable '0'

config collectd_iptables_match
	option table 'nat'
	option chain 'luci_fw_postrouting'
	option target 'MASQUERADE'
	option source '192.168.1.0/24'
	option outputif 'br-ff'
	option name 'LAN-Clients traffic'

config collectd_iptables_match
	option chain 'luci_fw_postrouting'
	option table 'nat'
	option target 'MASQUERADE'
	option source '10.61.230.0/24'
	option outputif 'br-ff'
	option name 'WLAN-Clients traffic'

config statistics 'collectd_irq'
	option enable '0'
	option Irqs '2 3 4 7'

config statistics 'collectd_iwinfo'
	option enable '1'

config statistics 'collectd_load'
	option enable '1'

config statistics 'collectd_memory'
	option enable '1'
	option ValuesAbsolute '1'
	option ValuesPercentage '0'

config statistics 'collectd_netlink'
	option enable '0'
	option IgnoreSelected '0'
	option VerboseInterfaces 'br-lan'
	option QDiscs 'br-lan'

config statistics 'collectd_nut'
	option enable '0'
	list UPS 'myupsname'

config statistics 'collectd_olsrd'
	option enable '0'
	option Port '2006'
	option Host '127.0.0.1'

config statistics 'collectd_ping'
	option enable '0'
	option TTL '127'
	option Interval '30'
	option Hosts '127.0.0.1'

config statistics 'collectd_processes'
	option enable '0'
	option Processes 'uhttpd dnsmasq dropbear'

config statistics 'collectd_sensors'
	option enable '0'

config statistics 'collectd_splash_leases'
	option enable '0'

config statistics 'collectd_tcpconns'
	option enable '0'
	option ListeningPorts '0'
	option LocalPorts '22 80'

config statistics 'collectd_thermal'
	option enable '0'
	option IgnoreSelected '0'

config statistics 'collectd_uptime'
	option enable '0'

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option ifname 'eth0'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option proto 'dhcp'
	option delegate '0'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'WLAN_USB'
	option proto 'static'
	option delegate '0'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

config interface 'WLAN_EMBED'
	option proto 'static'
	option ifname 'radio0.network1'
	option delegate '0'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	list dns '8.8.8.8'
	list dns '8.8.4.4'

package nft-qos

config default 'default'
	option priority_enable '0'
	option limit_enable '0'

config download
	option hostname 'undefined'
	option rate '50'
	option unit 'kbytes'

package rpcd

config rpcd
	option timeout '30'
	option socket '/var/run/ubus/ubus.sock'

config login
	option username 'root'
	option password '$p$root'
	list read '*'
	list write '*'

package sqm

config queue
	option debug_logging '0'
	option interface 'eth0'
	option qdisc 'cake'
	option linklayer 'ethernet'
	option script 'piece_of_cake.qos'
	option verbosity '2'
	option enabled '1'
	option overhead '8'
	option download '16500'
	option upload '16500'

package sqm-opkg

config queue 'eth1'
	option enabled '0'
	option interface 'eth1'
	option download '85000'
	option upload '10000'
	option qdisc 'fq_codel'
	option script 'simple.qos'
	option qdisc_advanced '0'
	option ingress_ecn 'ECN'
	option egress_ecn 'ECN'
	option qdisc_really_really_advanced '0'
	option itarget 'auto'
	option etarget 'auto'
	option linklayer 'none'

package system

config system
	option hostname 'OpenWrt'
	option ttylogin '0'
	option log_size '64'
	option urandom_seed '0'
	option log_proto 'udp'
	option conloglevel '8'
	option cronloglevel '5'
	option zonename 'Europe/Paris'
	option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'

config timeserver 'ntp'
	list server '0.openwrt.pool.ntp.org'
	list server '1.openwrt.pool.ntp.org'
	list server '2.openwrt.pool.ntp.org'
	list server '3.openwrt.pool.ntp.org'

config led
	option name 'green'
	option sysfs 'led0'
	option trigger 'netdev'
	option dev 'eth0'
	list mode 'tx'
	list mode 'rx'

config led
	option name 'red'
	option sysfs 'led1'
	option trigger 'timer'
	option delayon '250'
	option delayoff '2750'

package ucitrack

config network
	option init 'network'
	list affects 'dhcp'
	list affects 'radvd'

config wireless
	list affects 'network'

config firewall
	option init 'firewall'
	list affects 'luci-splash'
	list affects 'qos'
	list affects 'miniupnpd'
	list affects 'sqm'

config olsr
	option init 'olsrd'

config dhcp
	option init 'dnsmasq'
	list affects 'odhcpd'

config odhcpd
	option init 'odhcpd'

config dropbear
	option init 'dropbear'

config httpd
	option init 'httpd'

config fstab
	option exec '/sbin/block mount'

config qos
	option init 'qos'

config system
	option init 'led'
	option exec '/etc/init.d/log reload'
	list affects 'luci_statistics'
	list affects 'dhcp'

config luci_splash
	option init 'luci_splash'

config ntpclient
	option init 'ntpclient'

config samba
	option init 'samba'

config tinyproxy
	option init 'tinyproxy'

config upnpd
	option init 'miniupnpd'

config luci_statistics
	option init 'luci_statistics'

config sqm
	option init 'sqm'

package ucitrack-opkg

config network
	option init 'network'
	list affects 'dhcp'
	list affects 'radvd'

config wireless
	list affects 'network'

config firewall
	option init 'firewall'
	list affects 'luci-splash'
	list affects 'qos'
	list affects 'miniupnpd'

config olsr
	option init 'olsrd'

config dhcp
	option init 'dnsmasq'
	list affects 'odhcpd'

config odhcpd
	option init 'odhcpd'

config dropbear
	option init 'dropbear'

config httpd
	option init 'httpd'

config fstab
	option exec '/sbin/block mount'

config qos
	option init 'qos'

config system
	option init 'led'
	option exec '/etc/init.d/log reload'
	list affects 'luci_statistics'
	list affects 'dhcp'

config luci_splash
	option init 'luci_splash'

config upnpd
	option init 'miniupnpd'

config ntpclient
	option init 'ntpclient'

config samba
	option init 'samba'

config tinyproxy
	option init 'tinyproxy'

package uhttpd

config uhttpd 'main'
	list listen_http '0.0.0.0:80'
	list listen_http '[::]:80'
	list listen_https '0.0.0.0:443'
	list listen_https '[::]:443'
	option redirect_https '1'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option ubus_prefix '/ubus'

config cert 'defaults'
	option days '730'
	option key_type 'rsa'
	option bits '2048'
	option ec_curve 'P-256'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'OpenWrt'

package uhttpd-opkg

config uhttpd 'main'
	list listen_http '0.0.0.0:80'
	list listen_http '[::]:80'
	list listen_https '0.0.0.0:443'
	list listen_https '[::]:443'
	option redirect_https '1'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'

config cert 'defaults'
	option days '730'
	option key_type 'rsa'
	option bits '2048'
	option ec_curve 'P-256'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'OpenWrt'

package upnpd

config upnpd 'config'
	option download '1024'
	option upload '512'
	option internal_iface 'lan'
	option port '5000'
	option upnp_lease_file '/var/run/miniupnpd.leases'
	option enabled '1'
	option uuid '343fdcb9-8612-4519-ae66-b33361201fa8'

config perm_rule
	option action 'allow'
	option ext_ports '1024-65535'
	option int_addr '0.0.0.0/0'
	option int_ports '1024-65535'
	option comment 'Allow high ports'

config perm_rule
	option action 'deny'
	option ext_ports '0-65535'
	option int_addr '0.0.0.0/0'
	option int_ports '0-65535'
	option comment 'Default deny'

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option hwmode '11g'
	option channel '10'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-1/2-1:1.0'
	option hwmode '11g'
	option channel 'auto'
	option country 'FR'
	option htmode 'HT20'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option key 'XXXXXXXXX'
	option network 'WLAN_USB'
	option ssid 'Hogwarts Express'
	option disassoc_low_ack '0'
	option encryption 'psk2+ccmp'
	option wmm '0'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Alohomora'
	option encryption 'psk2'
	option hidden '1'
	option key 'XXXXXXXXXXX'
	option network 'WLAN_EMBED'
	option disabled '1'

package wrtbwmon

config wrtbwmon 'general'
	option persist '0'

If anyone have an idea, thanks =)

Try to set a channel which is as away as possible from interference.
If there is an option for maximum distance or optimize distance, make sure you make it at least twice the radius of the coverage.

I live out of town, so there is not much noise here.

Here a channel scan, Lord Voldemodem is my modem, Hogwarts Express the openwrt with the netgear a6210.

I'll try playing with the maximum distance setting tomorrow

Thanks @trendy

It should not be much of a problem, but you could shift the Lord a couple of channels higher.
Also for the sake of this troubleshooting, make sure that the phone won't automatically connect to the Express SSID.
Set the maximum distance and let us know how it goes.

Please check what is the signal strength for client device. It is possible that you see 4/5 quality on client device, but power received by A6210 is really weak so, under a stable margin.

Note that some client devices have limited power on higher 5GHz channels - please try lower channel like 36, 40, 44, 48 instead of auto

@trendy
@lukasz92

you could shift the Lord a couple of channels higher.

Well, it is now disabled as I don't need it anymore.

make sure that the phone won't automatically connect to the Express SSID.

Done, same result

Set the maximum distance and let us know how it goes.

Tried 50, then 75, all devices disconnect at the same distance :frowning:

check what is the signal strength for client device.

Just before disconnection (in openwrt wireless page):
gnome-shell-screenshot-ZIOMT0

please try lower channel like 36, 40, 44, 48 instead of auto

I'm on 2.4Ghz, I have some IoT that need 2.4 :confused: so I can't change
But I fixed the channel to 6 where there's no other devices, devices still disconnect :frowning:

I also moved the devices to another place where there is less obstacle, same problem


At this point, I think it might be a driver issue, and the only workaround I think of is to use the embed Rpi wifi as a second access point, using the same SSID, maybe with mesh feature.

Could you help me to build this mesh configuration while we find the driver issue?

Thanks


Edit: Could it be due to the limited tx power? https://github.com/openwrt/mt76/issues/172