Router internet randomly crashed (R7800, 19.07.3)

I'm unable to ssh or ping the router after the crash.

Here's the log:

Additional Information:
Router: R7800
Firmware: OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363

I already tried reflashing the firmware which had fixed the same issue prior but the crashes before didn't output any logs at all. I think the issue started occuring on the 19 branch but I'm not 100% sure.

The settings I changed are wifi, port fowarding, firewall rules, SQM, and setting Pi-Hole as my DHCP server and DNS. No other changes are made which would make it randomly crash.

Zero information. Zero help ... I mean what you expect?
At least something like: I have running OpenWrt version xyz on Router abc? I have this issue since I installed OpenWrt or since I upgraded from version x to y ...
If I would be Mentalo I would guess you have simply choosen the wrong WLAN channel.

add more tempo on u boot , and information in this thread

I added some more information but I think the 19.07 branch just isn't stable for my router. Might test the 18 branch or just go back to using Voxel's firmware as I would prefer stability over feature.

I would wonder if r7800 isn't stable because it is the most popular modern router in this community.

First you should change the topic into sth. like: "Netgear R7800 randomly crashes". To get the attention of other R7800 users. I forgot that to mention before.

There are two threads in this forum where you could search if there is an stability issue on the WAN interface.

Second link is a community build by hnyman. You could try this build and see if the issue is solved there. There is a master and 19.07 build available.

You could provide/check the bootlog/syslog for any errors also. You could test with a fully reseted device (just plain internet configuration), to see if the crashes remain. In addition you could revert back to factory firmware to see if the router is stable then and possibly conclude to an OpenWrt related issue. For me (I may be wrong) it looks like an Wifi related issue. Is your internet connection stable if Wifi is disabled? If yes then you the error could be found in your configuration (uci show wireless).

Another possibility is a faulty cable (try to change). If that does not solve your problem it could be a hardware failure or maybe the modem in front is causing internet connection issues.

1 Like

I think it might have to do with my change of wifi settings as the crash started occurring after tried changing the channels. However, I reverted my changes but the crashes still persist and there were no other changes besides this. Is there a possibility that the settings didn't save correctly?

Also I have already reverted back to the voxel's firmware, which is essentially stock netgear firmware and I haven't experienced any issues yet. This leads me to believe that it is an issue with OpenWRT's firmware or it could be some setting I set that caused the crash.

I did noticed however that after reverting back to voxel's firmware, my previous configuration settings were still there. Does reflashing the firmware not wipe out the existing storage? Firefox was also redirecting me to OpenWRT's web page despite loading the stock firmware already, but clearing my browsing settings resolved this.

It depends how OpenWrt and Factory Firmware is using the flash device. The settings from my router are not touched by OpenWrt. If I flash back Factory Firmware all settings are still there.

I don't know how long you are using OpenWrt nor if it was running without any issue before. But as you said you made a specific setting and the problem appeared I would assume that this settings were causing the issue. Without knowing what you have changed it is just guessing what was causing this issue. Fail configuration does not mean that it is a bug. In easy case it does nothing. In other cases you have crashes or unpredictable behaviour.

I would flash back OpenWrt and doing a factory reset right after first boot. Then start over configuring OpenWrt.