Router gets public WAN IP but no internet connection

Hi!

I have a strange problem regarding cable modem/router ("Vodafone Connect Box", vendor is Compal) in combination with a ASUS RT-AC68U with OpenWRT 22.03.3.

My connection (Vodafone Germany) is native IPv4 (no dual-stack or dual-stack lite) and the cable router is configured as bridge.

Everything worked fine for years till my ISP did some maintenance on their infrastructure at few weeks ago.

On the day of maintenance the connection got lost and did not came back automatically, so i rebooted the cable modem.
After that my router got as usual a public IP address, subnet mask and gateway via ISPs DHCP. So far so good, but i still could not reach any external IP. Also not the ISPs gateway.

This is what i've mainly tried so far:

  • changed routers hostname and mac address of the WAN interface in case my ISP blocked the router somehow

  • resetted OpenWRT to factory settings - Same behavior as before reset

  • disabled firewall on OpenWRT - no difference

  • flashed router back to original ASUS firmware - Slightly different behavior: WAN interface gets not yet any IP

  • tried another OpenWRT based router (GL.iNet GL-SF1200): same behavior as the ASUS router

  • tried another NON-OpenWRT (some old fritzbox): Router gets public IP and can reach external targets!

  • connected my notebook directly to the modem: NIC gets public IP and can also reach external targets!

Any ideas what could try yet? Currently i set up up the router as exposted host on the modem, which works okay but i really would like to understand the problem.

TL;DR: OpenWRT router gets public IP on WAN interface via DHCP, but can not reach any internet targets.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd4a:8377:2c13::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr '04:92:26:61:f7:7c'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/10180000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

Some additional may useful information...

root@OpenWrt:~# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether 04:92:26:61:f7:78 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::692:26ff:fe61:f778/64 scope link 
       valid_lft forever preferred_lft forever
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 04:92:26:61:f7:7c brd ff:ff:ff:ff:ff:ff
5: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 04:92:26:61:f7:78 brd ff:ff:ff:ff:ff:ff
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 04:92:26:61:f7:7c brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd4a:8377:2c13::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::692:26ff:fe61:f77c/64 scope link 
       valid_lft forever preferred_lft forever
7: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 04:92:26:61:f7:7c brd ff:ff:ff:ff:ff:ff
8: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 04:92:26:61:f7:78 brd ff:ff:ff:ff:ff:ff
    inet 62.143.11.XXX/23 brd 62.143.11.255 scope global eth0.2
       valid_lft forever preferred_lft forever
    inet6 fe80::692:26ff:fe61:f778/64 scope link 
       valid_lft forever preferred_lft forever
root@OpenWrt:~# ip route list
default via 62.143.11.254 dev eth0.2  src 62.143.11.XXX 
62.143.10.0/23 dev eth0.2 scope link  src 62.143.11.XXX 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1 
root@OpenWrt:~# ping -c5 62.143.11.254
PING 62.143.11.254 (62.143.11.254): 56 data bytes

--- 62.143.11.254 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# traceroute 62.143.11.254
traceroute to 62.143.11.254 (62.143.11.254), 30 hops max, 46 byte packets
 1  62.143.11.XXX (62.143.11.XXX)  1812.360 ms !H  2031.060 ms !H  3118.620 ms !H

Check with your ISP, there's high probability (based on your test) that the issue is in their side.

You can try also turning off both the modem and your router for 5-10mins. Then turn on the modem first and wait 1-2mins before turning your router on. If still doesn't help, you need to talk to your ISP as there might be an issue on your line or on their side.

1 Like

Thanks, i tried turning the modem off for 15 minutes. no success.

As you suggested i will contact my ISP.

Your config looks pretty standard, so nothing jumps out as problematic.

In these two cases (plus the case with your OpenWrt routers), does the public IP remain the same, or does it change based on the device that is connected?

it will change because it is dynamic and i have to reboot the modem every time i switch the device behind it. But the IPs seem to be from the same pool(s).

I had this strange behavior in the past with my old coax ISP, basically it was something about MAC address's permission at ISP gateway. What I did back then was to connect my OpenWrt router all together with the modem once done and acquired the WAN IP, I unplugged the modem from the power cord and then back in and waited for the next day and voila I got internet back. I did this on the night so in the morning I have already internet, but this kept happening sometimes every once in a month.

It wouldn’t do trick on the security measures by cloning the MAC address, somehow it detected the original MAC. Other thing was to call them up and request them to accept my device but they refused to do that arguing me that my plan came with their provided router and I must use it with their config (pretty mutch they wanted to limit the wifi client up to just 5 devices!) and if I wanted to do what I was requesting them I had to upgrade my plan. Then I decided to flash their router with OpenWrt and never got a problem from then until my area was covered with fiber by a new ISP.

ISP’s are sketchy but my old one went to far (not only on this) and that’s why I decide to change them.

I talked to my ISP yesterday. Unfortunately only 1st level support.
With their tools they could not detect any problem, but they wanna escalate the issue.

I will report if something comes around.

ISP switched my cable modem. As it was to be expected this changed nothing.
I will contact them again, but i am afraid the chances are not good my problem will be solved this way.

Still i have some news. I was wondering whats the difference between my notebook directly connected to the modem vs the open wrt router.
The most obvious thing seems to be the DHCP client.
My notebook with linux uses (as the most distributons) dhclient while OpenWRT uses busyboxes udhcpd.
So i installed dhclient on the router and checked what happens if i request an ip with it:

dhclient -i eth0

On the first look nothing has changed. The routes listed by route -n are the same, ifstatus wan shows also the same values. Anyway i get a working connection!

i digged a little deeper by making some tcpdumps and spotted one major difference.
When a ip is requested by udhcpd the Gateway-IP value is 10.164.111.252, which is a private ip.

15:40:15.061208 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 04:92:26:61:f7:78, length 300, xid 0x8d699e1f, secs 109, Flags [none]
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 8: 
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Classless-Static-Route
	    Hostname Option 12, length 7: "OpenWrt"
	    Vendor-Class Option 60, length 12: "udhcp 1.35.0"
15:40:15.141729 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 368)
    10.164.111.252.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, hops 2, xid 0x8d699e1f, secs 109, Flags [none]
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.13
	  Gateway-IP 10.164.111.252
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Offer
	    Server-ID Option 54, length 4: 81.210.254.13
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 80.69.96.12,81.210.129.4
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"
15:40:15.148909 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 04:92:26:61:f7:78, length 300, xid 0x8d699e1f, secs 109, Flags [none]
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Request
	    Requested-IP Option 50, length 4: 62.143.11.XX
	    Server-ID Option 54, length 4: 81.210.254.13
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 8: 
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Classless-Static-Route
	    Hostname Option 12, length 7: "OpenWrt"
	    Vendor-Class Option 60, length 12: "udhcp 1.35.0"
15:40:15.164329 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 368)
    10.164.111.252.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, hops 2, xid 0x8d699e1f, secs 109, Flags [none]
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.141
	  Gateway-IP 10.164.111.252
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Offer
	    Server-ID Option 54, length 4: 81.210.254.141
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 81.210.129.4,80.69.96.12
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"
15:40:15.189249 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 368)
    10.164.111.252.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, hops 2, xid 0x8d699e1f, secs 109, Flags [none]
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.13
	  Gateway-IP 10.164.111.252
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 81.210.254.13
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 80.69.96.12,81.210.129.4
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"
15:40:15.221230 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 368)
    10.164.111.252.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, hops 2, xid 0x8d699e1f, secs 109, Flags [none]
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.141
	  Gateway-IP 10.164.111.252
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 81.210.254.141
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 81.210.129.4,80.69.96.12
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"

Doing the same with dhclient, the responded Gateway-IP is 176.199.112.252 which is a public ip.

15:47:42.704875 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 04:92:26:61:f7:78, length 300, xid 0x8e152338, Flags [none]
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    Parameter-Request Option 55, length 7: 
	      Subnet-Mask, BR, Time-Zone, Default-Gateway
	      Domain-Name, Domain-Name-Server, Hostname
	    Client-ID Option 61, length 19: hardware-type 255, 26:61:f7:78:00:01:00:01:2b:d6:be:1e:04:92:26:61:f7:78
15:47:42.842817 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 368)
    176.199.112.252.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, hops 2, xid 0x8e152338, Flags [none]
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.141
	  Gateway-IP 176.199.112.252
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Offer
	    Server-ID Option 54, length 4: 81.210.254.141
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 80.69.96.12,81.210.129.4
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"
15:47:42.846757 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 04:92:26:61:f7:78, length 300, xid 0x8e152338, Flags [none]
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Request
	    Server-ID Option 54, length 4: 81.210.254.141
	    Requested-IP Option 50, length 4: 62.143.11.XX
	    Parameter-Request Option 55, length 7: 
	      Subnet-Mask, BR, Time-Zone, Default-Gateway
	      Domain-Name, Domain-Name-Server, Hostname
	    Client-ID Option 61, length 19: hardware-type 255, 26:61:f7:78:00:01:00:01:2b:d6:be:1e:04:92:26:61:f7:78
15:47:42.912717 IP (tos 0x0, ttl 64, id 0, offset 0, flags [DF], proto UDP (17), length 368)
    176.199.112.252.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, hops 2, xid 0x8e152338, Flags [none]
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.141
	  Gateway-IP 176.199.112.252
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 81.210.254.141
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 80.69.96.12,81.210.129.4
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"
15:47:53.611486 IP (tos 0x0, ttl 64, id 17283, offset 0, flags [DF], proto UDP (17), length 328)
    62.143.11.XX.68 > 81.210.254.141.67: BOOTP/DHCP, Request from 04:92:26:61:f7:78, length 300, xid 0x7e9b7337, secs 208, Flags [none]
	  Client-IP 62.143.11.XX
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Request
	    Parameter-Request Option 55, length 7: 
	      Subnet-Mask, BR, Time-Zone, Default-Gateway
	      Domain-Name, Domain-Name-Server, Hostname
	    Client-ID Option 61, length 19: hardware-type 255, 26:61:f7:78:00:01:00:01:2b:d6:7c:62:04:92:26:61:f7:78
15:47:53.688627 IP (tos 0x0, ttl 55, id 27730, offset 0, flags [DF], proto UDP (17), length 368)
    81.210.254.141.67 > 62.143.11.XX.68: BOOTP/DHCP, Reply, length 340, xid 0x7e9b7337, secs 208, Flags [none]
	  Client-IP 62.143.11.XX
	  Your-IP 62.143.11.XX
	  Server-IP 81.210.254.141
	  Client-Ethernet-Address 04:92:26:61:f7:78
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: ACK
	    Server-ID Option 54, length 4: 81.210.254.141
	    Lease-Time Option 51, length 4: 5400
	    Subnet-Mask Option 1, length 4: 255.255.254.0
	    Default-Gateway Option 3, length 4: 62.143.11.254
	    Domain-Name-Server Option 6, length 8: 80.69.96.12,81.210.129.4
	    NTP Option 42, length 8: 216.239.35.4,216.239.35.12
	    RN Option 58, length 4: 2700
	    POSIX-TZ Option 100, length 44: "CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00"

Anyway, the resulting default gateway (show by ip -a / route -n ...) and other values seem to be the same - actually - correct ones. but only the connection after fetching ip by dhclient is working.

I am able to reproduce the issue any number of times by calling:

dhclient -i eth0.2 ... working connection
udhcpc -i eth0.2 ... non working connection
dhclient -i eth0.2 ... working connection...

I'm also affected by this issue since 3rd of june.
I even flashed 23.05.0-RC1 on my FB404 to try, same result :frowning_face:
I found @caspla 's post in the vodafone community which lead me here.
In between there was another post in the vodafone community:
https://forum.vodafone.de/t5/Geräte/Bridge-Mode-funktioniert-plötzlich-nicht-mehr-Technik-Support/m-p/3058891#M225130 (it's in german...)
It suggests to enter "something" into the dhcp client option 60 field ???
According to the logs provided by caspla
udhcpc sents option 60 : length 12: "udhcp 1.35.0"
whereas
dhclient dones'nt sent anything.
Next question: how to supress udhcpc's option 60 in the dhcp discover broadcast ?

Cheers,
Thomas

ctrl+f "sendopts" looks promising.

Something like this?

config interface 'wan'
    option sendopts '60:openwrt'

I will try by myself tomorrow.

Good news! I've got a working connection after entering something
in the WAN > Advanced Settings > Vendor Class to send when requesting DHCP (see screenshot).

image

This will set the vendorid option in the config file:

config interface 'wan'                
        option device 'eth0.2'        
        option proto 'dhcp'           
        option vendorid 'openwrt'

I didn't tried yet if setting dhcp option 60 as @tomtom mentioned would have the same effect.

2 Likes

Al right, i just learned that vendor class is the same as option 60 :smiley:

1 Like

That is great news,
I will also switch to bridge mode within the next minutes :grinning:

Thanks,
Thomas

Back in business in bridge mode.
Did some "investigation" during the day, outcome is:

2 Likes

One more thing left.
according to the tcpdumps provided by "caspla" udhcp(busybox) sends

Vendor-Class Option 60, length 12: "udhcp 1.35.0"

when no option is specified.

Looks like Vaderfone's DHCP server does not like this option in the client request.
I'm wondering what would happen if I would set

vendorid 'udhcp 1.35.0'

Maybe I can try on the weekend.