Router for multiple WLAN / LAN

I want to by a new router for the following scenario:
I need 3 separate wifi networks (all 2.5GHz and 5GHz) and each of those should be connected to one or more LAN ports.
My current favorite is the Archer C7 (v5). Is this scenario possible with it?

It looks quite possible with this device. But I wouldn't buy it now.

The Archer C7 and routers of its class are no longer competitive at their price. Multi-core ARM-based units with current-generation wireless, and much greater flash and RAM capacity are available at comparable cost in most markets.

Would the AVM FRITZ!Box 4040 be a better option? Or what spec should I look for?
The thread about enthusiast is rather confusing. I'm looking for something with good support and easily available in Germany.

For example, yes - ZyXEL NBG6617 or Linksys EA6350v3 (careful here, only v3 is supported, v1 or v2 never will be - so it's a bit of a gamble what you'll get…) would be other specimens.

Thanks for your help! While I wait for the FRITZ!Box 4040 to arrive, I started digging around how to configure it. My understanding so far is that with the IPQ4018 it is not as straightforward as with other devices.
I probably need something like this here, only with a third vlan:


I am a bit confused why port 5 never shows up in the config. Port 5 is the WAN port right?
The switch_vlan defines which ports belong to which vlan, but what does the bridge do?

The “Internet” port is “hard wired” to one of two Ethernet MACs (eth0/eth1) by the ipq40xx driver. A bridge is needed if you want to, for example, connect the LAN ports to VLAN 100 on the Internet port as the switch driver can’t do that (as far as I know). For other kinds of config, the bridge is generally only needed to, for example, bridge wireless and LAN.

Avoid using VLAN 1 and 2 in custom config. They’re special for the driver.

I'm struggling with the wan port. An IPv4 address gets assigned via DHCP but even if I ssh into the 4040 I can't ping the router which provided the address. This is the config for the wan port:

config interface 'wan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option ports '0t 5'
        option vid '9'

Do I need the bridge? It didn't change anything.

I captured the traffic on the DSL router (also a fritzbox).
I can see the DHCP packages. And then the fritzbox 4040 starts sending arp requests:

Who has 192.168.178.1? Tell 192.168.178.67

But there is never an answer to those requests.

Change eth1 to eth1.9.

1 Like

That did it! Thanks!