Rollback WRT3200ACM to 19.x?

luci-app-advcanced-reboot

There is a little known mvebu-specific way: OpenWrt does not use the pretty large "syscfg" partition, where the Linksys OEM firmware stores intermediate files.

OpenWrt only uses that partition to store the config backup archive .tar.gz during sysupgrade. And after the sysupgrade the archive gets deleted.

But otherwise the partition is unutilised, but it is always mounted at /tmp/syscfg. That looks confusing, as /tmp is ramdisk, but yes, there is a permanently mounted large flash partition at /tmp/syscfg. And that is common and visible to both dual-boot partitions.

So, you could could make a backup from your settings (with the sysupgrade script) and store that to some new directory in /tmp/syscfg. You can then later easily restore them (with the sysupgrade script) to the then running partition.

2 Likes

Okay so I was able to flash over to 19.07.8, using the factory image was the trick and I didn't get the erorr I did previously. Now it's really weird because my AC wifi just doesn't work anymore. It originally worked fine when I was using 19.07.8, then I had my issues with 21.x, and now being back on 19.07.8 has somehow broken it.

Are you sure that you have not restored "newer" configs from a future firmware (21.02) to the old 19.07 ...

Some options do change between versions, e.g. the wifi band option is new in master and 21.02, but is not supported in 19.07

Example from my routers:

This is from a new style config (master): option band '5g'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option cell_density '0'
        option htmode 'HE40'
        option channel '44'

While this is the old style: hwmode '11a'

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'FI'
        option log_level '2'
        option cell_density '0'
        option htmode 'VHT40'
        option txpower '21'
        option disabled '0'

Note that you can regerate the 19.07 default wifi config with wifi config, which only works if you have no /etc/config/wireless file.

root@router1:~# cd /etc/config/
root@router1:/etc/config# mv wireless wireless.backup
root@router1:/etc/config# wifi config
root@router1:/etc/config# ls -l wireless*
-rw-r--r--    1 root     root           707 Sep 23 19:14 wireless
-rwxr-xr-x    1 root     root          1030 Sep 19 22:41 wireless.backup

There is now a new "wireless" with default contents. (in addition to your old settings in wireless.backup)

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '56'
	option htmode 'VHT40'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key 'xxx'
	option ssid 'yyy'
	option encryption 'psk-mixed'

This is what I have now, it looks like the old style. When I reflashed I made sure to exclude keeping the config, but it seemed inconsistent. At least the IP restarted with OpenWRT named AP and the IP reset as well

you are missing the country and txpower options. (I do not remember if they are mandatory)

what does you kernel and system logs show about wifi (and hostapd)? Usually there are explanations if you do "wifi up".

I added country code and power, it seemed like they were optional but I can't be sure. Still doesn't work.

Thu Sep 23 09:41:57 2021 daemon.notice hostapd: wlan0: INTERFACE-ENABLED

Thu Sep 23 09:41:57 2021 daemon.notice hostapd: wlan0: INTERFACE-DISABLED

Thu Sep 23 09:41:57 2021 daemon.err hostapd: nl80211: Could not configure driver mode

Thu Sep 23 09:41:57 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0

Thu Sep 23 09:41:57 2021 daemon.err hostapd: nl80211 driver initialization failed.

Thu Sep 23 09:41:57 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED

Thu Sep 23 09:41:57 2021 daemon.notice hostapd: wlan0: AP-DISABLED

Thu Sep 23 09:41:57 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING

Thu Sep 23 09:41:57 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started

Thu Sep 23 09:41:57 2021 daemon.notice netifd: radio0 (6518): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory

Thu Sep 23 09:41:57 2021 daemon.notice netifd: radio0 (6518): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process path (/proc/exe)

Thu Sep 23 09:41:57 2021 daemon.notice netifd: radio0 (6518): Command failed: Invalid argument

Thu Sep 23 09:41:57 2021 daemon.notice netifd: radio0 (6518): Device setup failed: HOSTAPD_START_FAILED

Thu Sep 23 09:41:57 2021 user.notice mac80211: Failed command: iw phy phy1 set antenna 0xffffffff 0xffffffff

Thu Sep 23 09:41:57 2021 daemon.notice netifd: radio1 (6595): command failed: Not supported (-95)

Thu Sep 23 09:41:57 2021 user.notice mac80211: Failed command: iw phy phy1 set distance 10

Thu Sep 23 09:41:58 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf

Thu Sep 23 09:41:58 2021 kern.debug kernel: [ 7018.271941] ieee80211 phy1: change: 0xffffffff

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.360188] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.367155] br-lan: port 2(wlan1) entered blocking state

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.372526] br-lan: port 2(wlan1) entered disabled state

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.377960] device wlan1 entered promiscuous mode

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.382751] br-lan: port 2(wlan1) entered blocking state

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.388088] br-lan: port 2(wlan1) entered forwarding state

Thu Sep 23 09:41:58 2021 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE

Thu Sep 23 09:41:58 2021 daemon.err hostapd: Using interface wlan1 with hwaddr MAC and ssid "ssid"

Thu Sep 23 09:41:58 2021 kern.debug kernel: [ 7018.447121] ieee80211 phy1: change: 0x100

Thu Sep 23 09:41:58 2021 kern.debug kernel: [ 7018.460176] ieee80211 phy1: change: 0x42

Thu Sep 23 09:41:58 2021 kern.info kernel: [ 7018.609082] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready

Thu Sep 23 09:41:58 2021 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ENABLED

Thu Sep 23 09:41:58 2021 daemon.notice hostapd: wlan1: AP-ENABLED

Thu Sep 23 09:41:58 2021 daemon.notice netifd: Network device 'wlan1' link is up

Thu Sep 23 09:42:05 2021 daemon.info hostapd: wlan1: STA <MAC> IEEE 802.11: associated (aid 1)

Thu Sep 23 09:42:05 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED  <MAC>

Thu Sep 23 09:42:05 2021 daemon.info hostapd: wlan1: STA  <MAC> WPA: pairwise key handshake completed (RSN)

Thu Sep 23 09:42:05 2021 daemon.info dnsmasq-dhcp[3260]: DHCPREQUEST(br-lan) 192.168.1.54  <MAC>

Thu Sep 23 09:42:05 2021 daemon.info dnsmasq-dhcp[3260]: DHCPACK(br-lan) 192.168.1.54  <MAC> work.lan

Thu Sep 23 09:42:05 2021 daemon.info hostapd: wlan1: STA  <MAC> IEEE 802.11: authenticated

channel 56 is dfs, so make sure that you set contry code FR,and leave txpower to auto

CC, and TX power are ignored on the rango, but if the third radio is in play it has to be in agreement with CC of the mwlwifi radios.

Okay that's weird I guess I will choose another channel there really isn't any info there.

As for the third radio it's not enabled so I guess that doesn't matter?

Changing to a different channel seems to have no effect regardless of whether my computer should be able to connect I would assume that LUCI would tell me it's on and operational though no?

Appears to be some errors in your above log that will need to be sorted. If > 1 SSID on radios be sure to set unique BSSIDs per.

i would try to reset to default.
start from the beginning, just use the first two radios, and make sure to set channel 36 on 5ghz, and leave all to default.

1 Like

I decided to go one further.

  1. I deleted the /etc/config/wireless file.
  2. wifi config
  3. wifi reload
  4. Went to the LUCI config to enable the NAC radio without changing any setting

Result: It just says "wireless is not associated" and shows "disabled." This is just to launch an unprotected AP called "OpenWRT"

Is there something that would persist from installing 21.x even though I downgraded to 19.x? It doesn't seem to find the wlan0

I did a logread

Thu Sep 23 18:58:14 2021 daemon.notice netifd: Network device 'wlan1' link is up
Thu Sep 23 18:58:18 2021 daemon.info hostapd: wlan1: STA 18:b4:30:83:35:99 IEEE 802.11: associated (aid 1)
Thu Sep 23 18:58:18 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 18:b4:30:83:35:99
Thu Sep 23 18:58:18 2021 daemon.info hostapd: wlan1: STA 18:b4:30:83:35:99 WPA: pairwise key handshake completed (RSN)
Thu Sep 23 18:58:18 2021 daemon.info dnsmasq-dhcp[3260]: DHCPDISCOVER(br-lan) 18:b4:30:83:35:99
Thu Sep 23 18:58:18 2021 daemon.info dnsmasq-dhcp[3260]: DHCPOFFER(br-lan) 192.168.1.52 18:b4:30:83:35:99
Thu Sep 23 18:58:29 2021 daemon.info dnsmasq-dhcp[3260]: DHCPDISCOVER(br-lan) 18:b4:30:83:35:99
Thu Sep 23 18:58:29 2021 daemon.info dnsmasq-dhcp[3260]: DHCPOFFER(br-lan) 192.168.1.52 18:b4:30:83:35:99
Thu Sep 23 18:58:29 2021 daemon.info dnsmasq-dhcp[3260]: DHCPREQUEST(br-lan) 192.168.1.52 18:b4:30:83:35:99
Thu Sep 23 18:58:29 2021 daemon.info dnsmasq-dhcp[3260]: DHCPACK(br-lan) 192.168.1.52 18:b4:30:83:35:99 nest.lan
Thu Sep 23 18:58:29 2021 daemon.info hostapd: wlan1: STA 18:b4:30:83:35:99 IEEE 802.11: authenticated
Thu Sep 23 18:59:12 2021 daemon.info hostapd: wlan1: STA 72:3f:bb:3b:40:99 IEEE 802.11: associated (aid 2)
Thu Sep 23 18:59:13 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 72:3f:bb:3b:40:99
Thu Sep 23 18:59:13 2021 daemon.info hostapd: wlan1: STA 72:3f:bb:3b:40:99 WPA: pairwise key handshake completed (RSN)
Thu Sep 23 18:59:13 2021 daemon.info dnsmasq-dhcp[3260]: DHCPREQUEST(br-lan) 192.168.1.128 72:3f:bb:3b:40:99
Thu Sep 23 18:59:13 2021 daemon.info dnsmasq-dhcp[3260]: DHCPACK(br-lan) 192.168.1.128 72:3f:bb:3b:40:99
Thu Sep 23 18:59:13 2021 daemon.info hostapd: wlan1: STA 72:3f:bb:3b:40:99 IEEE 802.11: authenticated
Thu Sep 23 18:59:31 2021 kern.info kernel: [40482.690479] device wlan1 left promiscuous mode
Thu Sep 23 18:59:31 2021 kern.info kernel: [40482.694998] br-lan: port 2(wlan1) entered disabled state
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: wlan1: interface state ENABLED->DISABLED
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 72:3f:bb:3b:40:99
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 18:b4:30:83:35:99
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: wlan1: AP-DISABLED
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Thu Sep 23 18:59:31 2021 daemon.notice hostapd: nl80211: Failed to remove interface wlan1 from bridge br-lan: Invalid argument
Thu Sep 23 18:59:31 2021 kern.debug kernel: [40482.836535] ieee80211 phy1: staid 2 deleted
Thu Sep 23 18:59:31 2021 kern.debug kernel: [40482.857104] ieee80211 phy1: staid 1 deleted
Thu Sep 23 18:59:31 2021 kern.debug kernel: [40482.877370] ieee80211 phy1: change: 0x40
Thu Sep 23 18:59:31 2021 kern.debug kernel: [40482.958389] ieee80211 phy1: change: 0x100
Thu Sep 23 18:59:38 2021 user.notice mac80211: Failed command: iw phy phy0 set antenna 0xffffffff 0xffffffff
Thu Sep 23 18:59:38 2021 daemon.notice netifd: radio0 (14761): command failed: Not supported (-95)
Thu Sep 23 18:59:38 2021 user.notice mac80211: Failed command: iw phy phy0 set distance 0
Thu Sep 23 18:59:38 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Thu Sep 23 18:59:38 2021 kern.debug kernel: [40489.789732] ieee80211 phy0: change: 0xffffffff
Thu Sep 23 18:59:38 2021 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Thu Sep 23 18:59:38 2021 kern.info kernel: [40489.902953] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Sep 23 18:59:38 2021 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Thu Sep 23 18:59:38 2021 daemon.err hostapd: nl80211: Could not configure driver mode
Thu Sep 23 18:59:38 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Thu Sep 23 18:59:38 2021 daemon.err hostapd: nl80211 driver initialization failed.
Thu Sep 23 18:59:38 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Thu Sep 23 18:59:38 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Thu Sep 23 18:59:38 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Thu Sep 23 18:59:38 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Thu Sep 23 18:59:38 2021 daemon.notice netifd: radio0 (14761): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Thu Sep 23 18:59:38 2021 daemon.notice netifd: radio0 (14761): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path (/proc/exe)
Thu Sep 23 18:59:38 2021 daemon.notice netifd: radio0 (14761): Command failed: Invalid argument
Thu Sep 23 18:59:38 2021 daemon.notice netifd: radio0 (14761): Device setup failed: HOSTAPD_START_FAILED

There should be no permanent changes.

I suggest that you reset the router to defaults, regarding all settings.

As mvebu moved to DSA, there are incompatible changes e.g. in network config ( including switch) config. If you have restored 21.02 network config files into 19.07, you will run into trouble.

Network, system and wireless are the most incompatible config files between 19.07 and 21.02.

If you want to copy settings backward , it is best to just use the old config file as reference in reconfiguration, and not actually use them.

I never actually copied anything between settings. I was mostly wanting convenience for my hosts and ethers but I just did everything fresh with no copies.

what does the kernel log say, when you boot the device?
Are the wifi devices initialised properly?

Maybe this can be helpful for you as well

I had to tick legacy on a 2.4ghz WiFi for one of my laptops. Which has only 2.4ghz. It worked on 19.7 or less without it but the latest 19 and 21 needs it.

Okay so a completely clean reset, and then the most minimal wifi configuration possible seems to have fixed this. I am not sure what happened but I guess I won't venture to change bandwidth or region or channel ever again. Will also wait for a few changelogs in 21.x to see if I'll ever consider upgrading again.

Just be adviced that Linksys/Marvell/NXC stopped the mwlwifi driver development in early 2019, so the wireless in WRT3200ACM and WRT32X will be always broken regarding some wifi functionality: 802.11w, mixed WPA2/WPA3 etc.

1 Like