Reverting to original firmware on TP Link Archer C2600

Hello all.

I got a little bit in over my head on this.

I installed OpenWRT on my router and I'm getting 20Mbps speeds on a 300 download line (AC doesn't seem to be working right). It's a refurb so it might be the hardware. I decided to give the original firmware another go before I RMA but when I try doing it through the Web GUI I get a "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform." error.

I've done some googling and it seems like the process to reverting back is model-specific. I'm not good at all on a CLI and it seems like I could easily brick my router doing something like this.
Tried following this but I get an error on cmd that says "'dd' is not recognized as an internal...' error.
Tried the "debricking" part of this page but the part that says " Start a tftp server with the file ArcherC2600_1.0_tp_recovery.bin in its root directory" is just way beyond my capabilities (What's a TFTP server? How do I put that file in the root directory?)

Anway, I was just hoping anyone could help me out or give me some pointers on where to look.

If you SSHed and use command line, you could try sysupgrage -f to attempt to flash.

How do I do that?

How do I point the command line to the firmware file? TP Link's website gives you the firmware in a .zip file... will that work?

So I tried the TFTP method by following this guide with this addendum to no avail (see screenshot).
Everything seems to be working fine, but then the router still boots to OpenWRT, not the stock firmware.

I allowed firewall permissions on the TFTP Server program and disabled the firewall for good measure.

Any pointers?

  • Login to router via SSH
  • cd /tmp
  • wget http://<address_of_OEM>
  • sysupgrade -f /tmp/foo

I assume you'll unzip and stage the file...if not, the you should learn to also install tar and to unzip foo and then proceed to sysupgrade.

Thanks for the response, Ileachii.

Seems that it can't do SSL (screenshot at bottom).
Do I need to install that "ssl|tls package"?

Yes, that's correct.