Reverting Back to stock firmware EA8100 V1

I installed openWrt on linksys ea8100 V1 and i want to go back to stock linksys firmware can anyone guide me how to do that? I've tried updating to stock firmware using open wrt it uploads the firmware then router reboots into openwrt again


"Warning: this is a dual partition router. ie. the original Linksys firmware is written to two partitions. If you overwrite both partitions, there will be no method of reverting to booting and using Linksys firmware at this time."

Did you overwrite both partitions?

I don't know but i tried Advance reboot but it says unknown router ea8100v1 is not supported

I don't have one to query directly, so I'm not sure what "Advance reboot" is. I only mentioned the "both partitions" thing because it was a blindingly obvious warning on the support page for that device.

What is the "it" which is saying that? And what steps have you carried out to arrive that that response? Configuration? Cabling? Any buttons pressed? Anything else which might be relevant and help other people to help you?

I installed advanced reboot to openwrt from putty now when i go to advanced reboot tab I don't see two partitions instead (Warning: Device (linksys,ea8100-v1) is unknown or isn't a dual-partition device!) I see this
I did try to hard reset it by pushing reset button and I've tried updating to original firmware from upgrade firmware button in openwrt other then that i don't think i have done any other steps

In that case, the earlier question is still germane: did you overwrite both partitions?

Also see - there may be some information in there which might help to resolve your issue.

Some more reading material:"is+unknown+or+isn't+a+dual-partition+device"

I don't know if it is written on both partition i tried checking it by advanced reboot but i don't know why it is not showing partitions here

Is there any way i can go back to stock firmware at current position of the router?

Couldn't hurt to ask Linksys for support. The support staff might know stuff about the device, especially its storage, which isn't in any of the extensive documentation you've already read.

Interestingly, implies that the EA8100v1 is supported...

... but doesn't contain any JSON definition files for it.

Don't know why there appears to be a discrepancy there. may also be of interest.

What is the general method of flashing back stock firmware after opwnwrt if the router isn't dual partition and you just want to force flash it back

From the EA8100 hardware page:

The hardware is similar to the EA7500 v2, so the installation instructions there can also apply here.

Read the directions on the EA7500 page that describes the process to reboot into the second partition of your device.

My guess is you installed the wrong version of advanced reboot on your device when you used putty. If you didn't overwrite the other partition with the OEM firmware (i.e. you only installed OpenWRT one time) this process should work easily and only take a few moments.

Rule of thumb - don't install a custom firmware without knowing how to get back to the original firmware...

1 Like

yes it booted into other partition i flashed linksys firmware from there its back to stock now! Thanks a lot man you saved me a lot of time.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.