Revert TP-Link AX23 v1 to stock firmware


May i ask for instruction how to revert to stock firmware ?

Tried the OEM web recovery?

Hello, Yes - iam trying but it gets to 100% and nothign happens.

I installed again openwrt image(via OEM recovery menu), and it boots normally.(with openwrt)

Anyone ?

I cannot back to stock firmware using WEB recovery mode. Its going to 100% and nothing happens. When i reboot - openwrt loads again.

Then you'll need serial to figure out why.


Any luck with going back to stock firmware since I'm struggling with the same issue

Could you please provide pinout, and small knowhow to open serial connection? I have rasppbery pi and arduino - i hope its help. I have basic knowledge about that - but i need to have instructions.


use screen, minicom, etc ...

Hello ,

My console output when iam trying to flash stock firmware using OEM recovery menu:

My hardware is V1.2, and software is also for this revision.

U-Boot 1.1.3 (Feb 16 2022 - 16:26:34)

Board: Ralink APSoC DRAM:  128 MB

relocate_code Pointer at: 87f58000

Config XHCI 40M PLL 

flash manufacture id: 1c, device id 70 18

find flash: EN25QH128A

*** Warning - bad CRC, using default environment


Ralink UBoot Version:


ASIC MT7621A DualCore (MAC to MT7530 Mode)

DRAM_CONF_FROM: Auto-Detection 


DRAM bus: 16 bit

Xtal Mode=3 OCP Ratio=1/3

Flash component: SPI Flash

Date:Feb 16 2022  Time:16:26:34


THIS IS uboot

icache: sets:256, ways:4, linesz:32 ,total:32768

dcache: sets:256, ways:4, linesz:32 ,total:32768 

 ##### The CPU freq = 880 MHZ #### 

 estimate memory size =128 Mbytes

Press '4' or 't' to break the booting process

Press 'x' to enter recovery web server

..............................begin recovery process.




 NetTxPacket = 0x87FE7A80 

 KSEG1ADDR(NetTxPacket) = 0xA7FE7A80 

Trying Eth0 (10/100-M)

Waitting for RX_DMA_BUSY status Start... done


HTTP server is starting at IP:

HTTP server is ready!

## Error: request file name not suport!

Data will be downloaded at 0x80500000 in RAM

Upgrade type: firmware

Upload file size: 13294494 bytes

Loading: #################################

Firmware process cloud.

Firmware verify OK!

firmware(size 0xcadb9e) verify pass!

HTTP upload is done! Upgrading...

do http upgrade





[NM_Debug](nm_lib_readPtnTable) 00743: NM_PTN_TABLE_BASE = 0xfe0000

[NM_Debug](nm_lib_readPtnFromNvram) 00569: partition_used_len = 1054, requried len = 8192
[NM_Debug](nm_lib_readPtnTable) 00751: Reading Partition Table from NVRAM ... OK

[NM_Debug](nm_lib_readPtnTable) 00759: Parsing Partition Table ... OK

Firmware Recovery file length : 13294494

Firmware process id 2.

handle_fw_cloud 146

Image verify OK!

Firmware file Verify ok!

[NM_Debug](nm_buildUpgradeStruct) 01273: nm_buildUpgradeStruct 1273 87fe6d74

[NM_Debug](nm_buildUpgradeStruct) 01291: nFileBytes = 13290378

[NM_Debug](nm_lib_readPtnFromNvram) 00569: partition_used_len = 265, requried len = 4096

[Error]sysmgr_proinfo_buildStruct():  660 @ unknown id(device_name), skip it.

[Error]sysmgr_proinfo_buildStruct():  660 @ unknown id(country), skip it.

[Error]sysmgr_cfg_checkSupportList(): 1043 @ productVer 1.0 NOT Match.

[Error]sysmgr_cfg_checkSupportList():  911 @ Entry 0 NOT Match.

Firmware supports, check OK.

[NM_Debug](nm_lib_readPtnFromNvram) 00569: partition_used_len = 16, requried len = 256

 (curFw_ver, newFw_ver) == (3.0, 1.0) 

[NM_Error](nm_checkSoftVer) 00964: Firmwave not supports, check failed.

[NM_Error](nm_checkUpdateContent) 01221: the firmware software version dismatched

[NM_Error](nm_buildUpgradeStruct) 01316: checkUpdateContent failed.

Web recovery failed type 0.

## Error: HTTP ugrade failed!

Trying Eth0 (10/100-M)


HTTP server is starting at IP:

HTTP server is ready!

Ok, are there several version of the fw available?

[Error]sysmgr_proinfo_buildStruct(): 660 @ unknown id(device_name), skip it.
Would indicate the fw is incorrect in some way.

On vendor site, we have 3 firmwares for hardware V1.2.

Iam trying all of them - always the same results.

Maybe should i try firmware for V1 ?

I would expect the same result with v1.

Do you have any other options how to solve that problem?


I had v1 version of this router and had some luck with renaming the firmware to firmware.bin
and it only worked for the latest version

Basically the firmware was uploading from 0 to 100%, as usually it went to 3-4% and then skipped to 40%

and i was getting error when updating the firmware

I end up buying new router

If you can install openwrt (or openwrt is your current firmware) you may try to prepare sysupgrade like image from stock firmware and install it from openwrt web-interface.



I just followed intructions from 123serge123, and prepared sysupgrade(using stock firmware) and web tool:

I just flashed this sysupgrade under openwrt firmware upgrade page, and finally my AX23 boot with stock firmware (iam not lost any configuration!)

Thanks everyone for help :slight_smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.