Revert to stock firmware RT-AX53U

Dear All,

Today I have tried to revert from OpenWRT 22.03.4 to stock ASUS firmware using ASUS recovery tool as suggested on the initial page.

Strangely I was not able to upload the trx file to the router. Sometimes the process stucked at 20%, sometime at 70%. Fortunately this is just uploading, so it did not bricked the router.

Do you have any suggestion how to proceed? In the past I remember I did it correctly maybe from 22.03.03. Were there some change maybe in OpenWRT which now prevents this operation?

Thank you for the support.

Asus Firmware Restoration tool and the stock firmware don't care about what's currently on it.
So no, it has nothing to do with OpenWrt.
Check connections, or you can also use a proper tftp client instead of the Asus tool.

  • Power off the router.
  • Disable all interfaces on the PC you're going to use for restoring the firmware, except the ethernet interface going to the router, set a static IP on that interface ( is recommended by ASUS, don't know if exactly that one is required).
  • Start the router in Rescue Mode by pressing the Reset button and keep holding the Reset button pressed while powering on the router, release the Reset button at about 15 seconds after power on (Power LED should slowly blink indicating that the device is in Rescue Mode).
  • Upload the desired image to using your favourite TFTP client or the ASUS Firmware Restoration Utility (Power LED will stay lit during transfer & write, router will reboot after write is finished).
1 Like

Thank you. But it looks like that Asus Restoration Tool is not working properly.
I was thinking about this change: Git - openwrt/openwrt.git/commitdiff
Maybe partitions are messed up a little. But this not explains why I have different percentage during upload process after it fails.

Or the other point could be that I do not have real ethernet port, so I use it with an USB-C -> ETH converter.

No, I repeat, Rescue Mode doesn't know or care about what and how you configured whatever you had running on it.
If you are on a recent build that has the nested partitions you can write the trx file to the firmware partition, from inside OpenWrt:

  • rename the asus stock firmware to asus.trx or whatever you like (optional);
  • transfer the trx file to the device in /tmp using winscp or something;
  • write that file using mtd -r write asus.trx firmware
1 Like

Thank you. That worked great.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.