Revert to stock firmware Linksys WRT3200ACM

My Linksys WRT3200ACM came with intermittent connectivity issues. It will work fine for a while and then both LAN and WAN will fail until a system reboot. I'm returing it for an exchange but want to put stock firmware back on it before I do. Let's assume that I only know enough to find the stock firmware and access the router via PuTTY. After that, I'm clueless.

Same answer as before:
you need to use the sysupgrade command from SSH console (using putty) and use the "-F" force flag to override the format image check.
e.g. How to go back to stock firmware on wrt1900acs v2

You download the stock firmware with wget to /tmp and then flash it with sysupgrade. Adjust the commands below to the real link and filename.

commands for you:

cd /tmp
wget link-to-stock-firmware
sysupgrade -F -n /tmp/stock-firmware-file

hnyman, when flashing this way via wget, does the sha256 hash show up anywhere so one can gpg verify the integrity of what wget pulled? How exactly does one do this when using wget to pull the image straight to the router?

No, sha256 does not get shown.
But you can calculate it manually (with "sha256sum") after downloading and then verify it, before flashing.

cd /tmp
wget link-to-stock-firmware
sha256sum /tmp/stock-firmware-file
sysupgrade -F -n /tmp/stock-firmware-file
1 Like

I tried this from the Luci flash upgrade page first time around. The connection via ethernet keeps connecting and reconnecting every few seconds. Not sure if the power is cycling. I could see the words "smart wifi" in the browser tab when trying to load the router access page at 192.168.1.1 but it never loaded all the way. The best I ever got was this.

I tried 30/30/30, no change in behavior.

I contacted Linksys support; they had me pull the power cord, plug it back in wait two blinks of the power indicator led and repeated 3x. Apparently this is how to change which partition boots.

Following this instruction got me back to a working OpenWRT.

I tried flashing from Mac terminal by sshing in, downloading the latest stock firmware to /tmp and sysupgrading with -f -n flags. The flash was not successful. Same experience as above, again, using the firmware recovery got me back to a working OpenWRT configuration even though it supposedly is on the other partion, go figure.

The last time I tried flashing, I transferred a bash script to reset the VLAN as it was a prerequisite, I had not messed with VLAN, but I have no idea if the previous owner did. I SCP'd the vlan-reset script to the router. Changed permissions of the file to be executable for everyone. Ran the script, now I can't recover the OpenWRT access page at all, even after 30/30/30 or the firmware recovery steps.

So frustrating. All I want to do is get to a clean slate with stock firmware. I got this router from Walmart, refurb and with OpenWRT installed. Presumably, Walmart folks didn't even look at the firmware, I don't think it was supposed to come with OpenWRT installed.

After reading related links, I'm concerned that I may have flashed both partitions, and that neither partitions have a working firmware.

That may just be a browser cache error, or something similar. I have sometimes seen something
If you get the Linksys "smart wifi" logo, then that partition already had the Linksys firmware and that was running.

You may need to disconnect and reboot the PC (and clean the browser cache etc.)

Or try with another device.

That sounds suspicious. Reset VLAN?

You should look into getting into the Opwnwrt failsafe page during the boot process. Failsafe gets active before any of your network settings get applied.
https://wiki.openwrt.org/doc/howto/generic.failsafe

It is really unlikely that you would have both partitions rendered completely invalid.

Hmm, I was able to get back to a working OpenWRT configuration by following these instructions I got off of a comment for this YouTube video: Unbrick/flash firmware to Linksys Wrt1200/1900ac wireless routers

  1. Hold the reset button for 10 seconds
  2. Power the router off
  3. Power the router on and wait for the Ethernet light(s) to illuminate
  4. Immediately power the router off
  5. repeat steps 3 & 4
  6. repeat steps 3 & 4
  7. power the router back on and wait for the power light to stabilize
    ====

Going to look into failsafe mode and see what I can do with that.

Well, if there is a working Openwrt and you get into the SSH console, then there is no need for failsafe mode.

Just in case: You might reset all your settings so that you get the Openwrt defaults. (either "firstboot" command from SSH or reset button in LuCI.) Note that it resets all network settings, wifi and passwords and will revert the Openwrt side quite as just flashed.

Which version of Openwrt you are running?

You should be able to flash the OEM firmware with the SSH console commands above (sysupgrade -F -n). But after the router then boots, you need to reboot your PC and browse with a fresh browser to make sure that your browser only gets the Linksys firmware GUI components.

  1. Try installing eduperez'es updated wireless drivers for WRT3200ACM. Make sure to download the version corresponding to the version of LEDE/OpenWrt currently installed. That fixes most of WiFi issues.
  2. If that still doesn't work (or you don't want to bother, because it would require the use of SSH), and if you have only flashed LEDE/OpenWrt once you can use the luci-app-advanced-reboot package to reboot to the partition with the stock firmware. Linksys WRT3200ACM has two partitions and when you flash a firmware an alternative partition is overwritten and becomes main partition.

I can't install the luci-app-advanced-reboot package, unfortunately.

Edit, actually, I can, now that I'm on OpenWRT V 18

I just realized that the model indicated on the Luci page is not what I was expecting at all; it says Linksys WRT1900ACv2 wth.

Sticker on the bottom of the router and everywhere else (packaging etc.) says Linksys WRT3200ACM-RM2. I wonder if this is why none of the sys-upgrades or images are working. I had been using the Hardware Table for the WRT3200ACM

Hmm. Looking at the Table of Hardware for the WRT1900AC. What's the difference between Shelby and Cobra? They both purport support for v2.

Had tried upgrading to a higher version of OpenWRT hoping for better luck flashing to stock, or just better performance. I might be willing to learn my way around how OpenWRT works.

Or just return the router since it's not what it says it is on the tin?

Well, if you flash the WRT3200ACM router with a firmware meant for quite another router, no wonder that things do not work for you.

v2? Yeah, WRT1900ACS v2 hardware version, but that is not WRT3200ACM

Additionally, you have flashed it with a quite ancient 15.05.1 version from year 2015, instead of the current 18.06.1 release from this month. That 15.05.1 had no support for 3200ACM, as that router had not even been released then. WRT3200ACM has been supported since release 17.01

If you now have SSH console access, you can just download the current 18.06.1 firmware for WRT3200ACM and flash that (using the sysupgrade -F -n" to get rid of the wrong settings.

Alternatively, download and flash the correct OEM firmware, for 3200ACM.

Ps. you can see the whole WRT1x00ACx series (1200, 1900, 3200, 32x) in https://openwrt.org/toh/linksys/wrt_ac_series

It came with V 15.05.1, I've been trying to upgrade it to anything else all night. I was able to flash OpenWRT V 18 Shelby for WRT1900AC V2 to partition 2.

After that I was able to see that Partition 2 had OpenWRT V18 which is just flashed, and Partition still has OpenWRT V 15.05.1.

With that success, I decided to try to flash stock firmware for WRT1900AC V2 from partition 2 (as I understand it, performing the flashing from one partition does the flashing to the other partition) and see if it worked.

It sort of did. After flashing from ssh session (flashing via luci my stock flash image), I was able to get to the linksys stock firmware login page, but this is where it gets weird, it shows the luci page and then redirects to the linksys stock firmware login page, but it's a broken one, the end result is URL: http://192.168.1.1/cgi-bin/luci . Power cycled. No dice. Hard reset. Actually got a fully featured linksys login page, checked off the TOS box or whatever, and hit continue, erp, redirected to luci page, no dice. Is this is a case of a corrupt bootloader?

Going back to partition 2 to try and reflash partition 1 with the WRT3200ACM firmware and see what happens with that.

I was able to get to the linksys stock firmware login page, but this is where it gets weird, it shows the luci page and then redirects to the linksys stock firmware login page, but it's a broken one

That sounds like you just need to clear your cookies and cache from your browser, that's usually recommended when going from OpenWrt back to stock firmware.

2 Likes

I was able to get stock firmware working in partition 1 and the latest stable OpenWRT working in partition 2.

Looked in diagnostics to confirm model info, seems like it really is a WRT1900AC.

device::model_base=WRT1900AC
device::manufacturerDate=2016/01/20
device::hw_revision=2

Blah. It would have saved me so much grief if the router just said as much on the label. Considering returning the unit to Walmart. I wonder how the actual specs of this "refurbished" unit compare to the WRTAC3200 it purports to be. How would I go about exploring that without investing much money or time/energy if at all?

If you paid for a rango and got a cobra, probably not, depends on price. But the cobra does load power table from dts, depends on ones use case. And if it is actually a shelby V2, may as well get the rango.

Nevermind, if you've flashed two different revisions of OpenWrt already, both partitions got overwritten.

The luci-app-advanced-reboot package was still useful to me, it let me boot to the other partition in a straightforward manner. If only it would survive reboots. Mount_hd and installing to root did not persist, presumably because it's a squash fs. I didn't see a more straight forward way to accomplish the trick. The instructions for changing to the other partition by unplugging and plugging in the cables for ~2 seconds 3x was not reliable for me.

I needed to get this job done. I'm a noob, it works for me to just try and do, to learn from trial and error. I still don't entirely get how one is supposed to upgrade the firmware for one OS if it's done from the opposite partition firmware. Or how to boot back into OpenWRT once you're in Stock Linksys Firmware. It's a bit murky still.

I'm content with what I accomplished, even if I was terribly inefficient at it, it was a good learning experience.

You should have read the warning when rebooting to an alternative partition.

Is it possible that I installed the wrong firmware? I couldn't get a WRT3200ACM firmware working on this unit but I'll be the first to admit I'm mucking around and am ignorant about many commands and methods. Here is a picture of the on the router unit. I'm always open to understanding more. Illuminate me please, thanks.