Revert from DD-WRT


i am using openwrt for years now but i dont know whats wrong with the version 23.05.03 and the last versions. I didnt manage to get a Wireguard-Client working like i always do, a handshake is established but no default route was set so iam surfed on my normal isp ip. Where the VPN worked there were problems in combination with the pbr, it doesnt made local port available. Tailscale is completely broken a start is doesnt even possible because of wrong nftables tables. So i switched to dd-wrt and is not the same like openwrt. Openwrt was classes better. So i made an mistake and flashed openwrt directly from DD-Wrt WebUI so i landed on a broken (!?) Install of the original linksys firmware. The orange "amber:wan" is blinking and i can connect to the Standard Wifi but with no access to the WebUI. I did a port scan and ports from dns upnpd and smb are open but no port 80 or 443. So i tried to go back to the DD-Wrt Firmware (with the power on/off 3x trick) Than i tried to flash the original software of linksys via the command : "mtd -r write firmware.img linux" but i get an error. So now i am out of options and have to ask you for help perhaps someone have a tip to get back to openwrt !? Its an LinksysWRT 1900 acs v2 with 2 boot partitions. Eventually you have also a tip for a new router with ADSL+ Modem integrated, good performance, USB 3.0 and so on i didnt find any with that combination.
Thanks in advance !

A LinksysWRT 1900 acs v2 has 2 firmware partitions.
Are you at all still able to properly boot into any working firmware in any of the 2 partitions + access the corresponding web GUI?

Or are both partitions now somehow broken?

tftp images(s) to the device, maybe start with OEM to both partitions.

1 Like

Yes i have fully access to DD-WRT with WebUI and SSH where i have tried the mtd write command which i googled.

Any tries to flash over the WebUI i landed on the same broken Linksys Partition

Since you have access via DD-WRT, I would suggest that you take @anomeome 's advice and return to the vendor firmware on both partitions. This way you can essentially start from a clean slate.

1 Like

Please please tell me how !

You'll have to ask on the DD-WRT forums since your device is currently running that firmware.

That said... in general, you can usually use TFTP to flash one of the partitions (likely the first one). It will usually not flash the other partition, though.

Try using TFTP to flash a copy of the factory firmware. Then, boot into that partition and then use the web UI to flash the other partition with that same firmware.

If it turns out that you flash it but still end up in DD-WRT, you can try to change the boot partition via the command line. I don't know if it will work the same way as it does on OpenWrt (on a different device), but you can see the nvram commands I used on an EA6300 in this thread. If that doesn't work, ask on the DD-WRT forums about the process of changing the boot partition.... ultimately you want to get back to the linksys firmware on both partitions.

You caan tftp either one, or both, of the partitions.

But if DDWRT is still functioning, you should be able to go straight to OEM from the GUI (I assume), and as noted, check the website for the product; IIRC, you cannot go directly from DDWRT to OpenWrt.

A yes. I should clarify that I was thinking of tftp without a UART connection. If the UART is in use, it does make sense that you can flash both.