Revert back from OpenWrt to factory firmware TPlink WR940Nv6

hey guys , so I flashed my wr940NV6 to openWRT and I couldn't install any VPN app on it
""OpenWrt 18.06.0-rc1 r7090-d2aa3a1b62 / LuCI openwrt-18.06 branch (git-18.163.60998-c379f00)""

searched the software and find nothing , and all I want to configure OpenVPN on it . so prefer to flash it back to original firmware or someone can help me to switch it to DDWRT .

i'm an amateur in this , so take it easy on me

tried this command

cd /tmp
wget https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/08-22-2018-r36698/tplink_tl-wr940ndv5/factory-to-ddwrt-us.bin
mtd -r write /tmp/https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/08-22-2018-r36698/tplink_tl-wr940ndv5/factory-to-ddwrt-us.bin linux

SSH not working and don't know which one to install as I couldn't find anything in the software tab

Use OpenWrt 18.06.1.
Your device should support it.
And there's plenty of VPN-applications.


Mm, I see, you have 4/32 device:
https://openwrt.org/toh/tp-link/tl-wr940n
However it should be possible to install the packages in the RAM.

can u share me the link?

and when i'm flashing it through GUI i get this message

""The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

even the original TP-Link firmware is not accepting it

940n v6 does not enough flash memory to install vpn software.

so I copied the .bin file to the router but how can I execute it? I need someone to help me with the commands here

.bin file is copied to root/tmp

so I managed to flash it but now seems DDWRT firmware for this router is not supporting OpenVPN due lack of memory , now if someone can help me to revert it back to original firmware

seems the commands on DDWRT kinda different from OpenWRT
sysupgrade there is something else , tried mtd and write but also not working

See this link, section TFTP install. Rename stock firmware to wr940nv6_tp_recovery.bin
https://openwrt.org/toh/tp-link/tl-wr941nd

this was done finally , the issue was preventing me from completing it , the McAfee antivirus i've done that with another computer

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.