Restore Asus TUF AX4200 to the original Asus Firmware

Hi, I am not able to restore the TUF AX4200 to it's original firmware. I've tried to do it using recovery mode with Asus Firmware Restoration 3 times, tried different version of the asus firmware, different verion of the Firmware Restoration software. Also, I followed this guide https://openwrt.org/toh/asus/rt-ac58u#returning_to_stock and the result is the same, when I enter 192.168.1.1 openwrt still shows. Please help.

ASUS recovery is needed:
https://www.asus.com/support/faq/1000814/

yes, already did that, it's the same

also tried using putty to do sysupgrade still the same result, openwrt still here....

I also looked at this post and tried the method mentioned Revert to stock firmware RT-AX53U - #3 by molnaratt and when I use putty to mtd - r write factory.trx firmware it gives me an error "Could not open mtd device: firmware Can't open device for writing!" Please help

Do not attempt to recover using other device methods, only "clean" way is the ASUS tool, or if some developer shows how to convert asus trx into something that can be written to flash. You may accidentally destroy bootloader explicitly writing flash, then even asus recovery will not be able to help.

I tried it 5 times, it always just give me back Openwrt after. I've had several asus router and I know ASUS tool always worked, only on this TUF AX4200 I am having trouble going back to the original firmware.....

This works [facinstall] Package for easy installation factory images

1 Like

You are not right! The standard utility from Asus will not help you return to stock firmware.

The reason is described here: Asus TUF AX4200 support - #406 by remittor

Converting images cannot in any way cause the bootloader to be removed.

And without TRX files you can remove the bootloader.

1 Like