Resizing filesystems on embedded devices

I while back I tried OpenWRT on a VM and on an old consumer router to learn about it; I was able to do dynamic routing and various other pretty advanced configs easily, but I could never figure out the most basic tasks, like PBR. I moved on, no biggie.

Later, in this other thing, I learned it can be integrated with hostapd. My other APs are UniFis, I don't have system with a wireless interface that aren't Macs, the only place I have access to that was in that old router. I got half of it working but for the other part I needed to make a small installation.

The package is less than 1MB, but this blinking toaster somehow doesn't have the space for it which was odd because I could've sworn I saw it had over 100MB in something.

As it turned out, it was RAM. 119, I assume that's 128MB minus stuff, but only 2MB in storage. Two megabytes. How is that possible. I have so many questions but no time to ask them because right after that bar (in LuCI) there was another related to storage, the "temp space", that is more than double the size or the main storage, by more than double I mean 28.5 times the size of it (I did the math. Well… Spotlight, but y'know). I just need 1MB, kinda, it's really less than 700kB. :frowning:

Is this a partition? I read something about overlay somewhere just now, but I forgot where already. Can I edit it? Am I on camera?

This reminds me back on one of the VMs I tried OpenWRT in, I had set up a small 4TB array of disks (bigger without redundancy) that OpenWRT shared as an iSCSI target. It was really simple to set up. It's own filesystem was huge too, also an easy task using Fedora Live, I believe. Contrasts liike these were all over the place; the traditionally harder or more involved stuff was a breeze but the basics are a monumental task in OpenWRT… like this 1:28 split. It's insane.


What is the device in qustion?

ubus call system board

temp space is most likely /tmp which is tmpfs and is usually 0.5 times your RAM (it is not your persistent storage space).

1 Like

Yes, tmpfs is indeed RAM based. It cannot be used for extending the filesystem. But once we know what the device is, we might be able to recommend some options.