Request for help with first install of OpenWrt snapshot on a Fritzbox 7530

Thanks again for your support @andyboeh. Yes, I removed br-dsl already and simplified tmy network config. It takes me some time to figure out how to best accomplish my tasks. And YES, if you know how to to it, it's really simple to get it working - for a beginner... let's say not so easy.

Still not perfect as I get an alias of "wan" - but that's also on the top do list. As is setting up fast roaming with an old Netgear EX3700 I found. ddns is working, too - even https - nice :-). Too much to do, not enough time. But thanks again for your support - I'll dig through your config as well.

KR

1 Like

Can you please elaborate on what you changed to have the "Network device is not present" Eror go away? Or maybe post your current config file?
I am havin the same issue on a FB7530 with Openwrt 23.05.0, all additional FW files in the correct folders and even manually set the "Firmare File" option in ''Network => Interfaces => DSL''.
I am with the German Telekom, here's my config:

'config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8c:b815:0ddc::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'j'
        option tone 'b'
        option ds_snr_offset '0'
        option firmware '/lib/firmware/xcpe_8D1507_8D0901.bin'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr '74:42:7F:3A:DC:93'
        option mtu '1500'

config interface 'wan'
        option device 'dsl0.7'
        option proto 'pppoe'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

config device
        option type '8021q'
        option ifname 'dsl0'
        option vid '7'
        option name 'dsl0.7'

config interface 'test'
        option proto 'dhcp'
        option device 'lan4' 

You'll need to add this in your wan section sooner or later:

option password 'xxxxxxxx'
option username 'xxxxxxxxxxxxxxxxxxxx#0001@t-online.de'

and remove this whole part:

My configuration works really fine on DTAG VDSL.

Is the DSL modem connected? If you are using the LuCI web interface, the DSL status should be on the start page. Otherwise, run ubus call dsl metrics from the command line.

Thans for your wuick reply, I do get that i have to put in my identification for PPPoE to work.
But why do i need to remove the device config for the 801q device?
Ithought i needed that so i can use "dsl0.7" as a device in th "wan" interface and therefor tell it to use VLAN7

the s´dsl0 port shows up in the GUI as well as the DSL stauts further down on the start page.
I gues that means its connected?

It shouldn't really matter whether there is an explicit "8021q" section in the config. Without it, the VLAN interface should still created automatically as long as the WAN interface is configured to use dsl0.7. But having the section also shouldn't break anything.

The interface shows up in the web interface because it is configured. However, that doesn't necessarily mean that it exists as an actual Linux network interface. It is only actually created by the modem driver when it establishes a connection.

If you can see the message "Network device is not present" (as you mentioned earlier) that sounds like the interface doesn't actually exist. You can check using the web interface by going into "Network" -> "Interfaces" and then the "Devices" tab. If you hover over the network icon, the status of the interface should be shown.

Also, the actual DSL line state shown on the overview page should contain "Showtime" if the modem is connected.