Request for help with first install of OpenWrt snapshot on a Fritzbox 7530

A1 uses two different set ups in Austria. One is PPPoE on VLAN2, that is the newer configuration. The older ADSL connections use a different syntax. Are you on VDSL?

You do not need to set up any bridging or any VLANS. Just change the the device of interface pppoe to vlan0.2 and you're good to go! In LuCI, you might have to type dsl0.2 as it's usually not present.

Posting this from my Fritz!Box 7530 openWRTed... party time

image

Man, you made me glad! Thanks a lot for all the help! HIGHLY appreciated! Now I just have to reconfigure the LANs (to DHCP server) and hope not to loose connection :-). Be "right" back... in a few hours

Do yourself a favor and:
rename MODEM to wan and delete the existing wan before doing that.

I apologize for posting my somewhat specialized config as that clearly mislead you what you need for your network...

Looks a bit too complicated, I'm sure you can throw a few things out, but I'm glad it's working now!
I will switch my split-setup with a 7412 in bridge mode to a 7520 in router mode on the weekend. I can post my configuration in a few days (also A1).
My other 7520 is on a Fonira connection - there it's just DHCP over VLAN31, a bit easier to set up.

Edit:
This is the Fonira overview. You should have dsl0.2 instead of dsl0.31 and instead of DHCP client you should have PPPoE. You can delete WAN6 as you won't get an IPv6 address anyway (thank you, A1).
image

Edit2:
The wiki has a configuration example that should work fine on the 7530:

I intend to throw things out - but for now I am glad it works. I hope I can reconfigure the LAN ports to serve as a dhcp server without locking myself out (the next step)... THAT would be a pain in the ****. I'll backup my /etc/config/network for the time being (if locked out).
Then rename MODEM to WAN (polishing) and maybe I should password protect it.

I'll come back soon regarding firewall topics :-).
Thanks again and please feel free to post further advice :slight_smile:

DHCP on the LAN ports is the default configuration - did you change that?

@tmomas IMHO this thread should be split from the first post of @WotC into a now topic since it's not really related to the installation guide but deals with specific device problems.

2 Likes

I'm sorry for screwing up that post. For me it was a natural process as the installation of openWRT using the Wiki was the easiest part :-).

@andyboeh yes, i changed that on the LAN side for setup purpose. Not sure whether that was required, but think so. Do I have to reconfigure the LAN link (see my LUCI screenshot - there you see also it's set to DHCP client) or just change the protocol type in the config?
Maybe I should just reconfigure three of my four ports as DHCP Server, the fourth as client (to be on the safe side)? But then I would have to redo my 'br-lan' bridge I guess.

@andyboeh regarding the link to the ISP configuration: yes, read that but wasn't sure how it works out for me (e.g. my original Fritz!Box states annex a - the config annex b).

To continue that hijacked thread :innocent::

  1. any suggestions ad firewall?
  2. any idea how i can download the opkg repository (I learned that by using the snapshot opkg might stop working "soon"

kr

p.s. sorry for the late reply - forum rules :slight_smile:

No, it's not required to change the LAN confoguration - why should it be? You install OpenWrt, configure your computer as DHCP client and have access to the box at 192.168.1.1.

IDK how to configure it back, I never changed that.

AFAIK the Annex is not important for VDSL, only for ADSL.

ad 1: what do you want to change? The default firewall is fine from a security perspective.

ad 2: It could be that there is information on the Wiki, I never did that. I just upgrade to the latest snapshot if something breaks (or stay with a self-compiled image).

I connected the FritzBox to my LAN as a DHCP client so I could run opkg install etc. It was quite easy to transfer the image/sysupgrade via scp, but I had no idea how to connect the FritzBox to the internet before I got the DSL modem up and running.

Regarding the firewall: was not sure whether i need to configure it or not!
Ad upgrade: ah, so just download the syupgrade bin and install it keeping settings it is. Sounds good, thx.

Well, to get online you actually only need the firmware file, and this can be transferred via scp. But of course, DHCP client works.

You can also install attended sysupgrade, this will also keep your installed packages (i.e. upgrade them).

Okay, maybe I shouldn't have changed the settings. Switched my lan (br-lan; similar to yours @moeller0 ) from DHCP client to static and activated DHCP. Cannot login to openWRT anymore :sob:. I think this is what one would call a bricked device? Reflash like from the original Fritz! firmware doesn't work either... so no clue how to get that piece of electronics back online again :frowning:

Maybe try to follow:

Also please open a new thread as tis is way off-topic by now. You can always "summon" known users to a new thread by writing an at-sign (@) followed by their forum name, like @moeller0 and they should get a notification (that does not guarantee that they will respond, but at least they get information).

I tend to be relative tolerant to getting off-topic, but this is really more of an OpenWrt/DSA 101 than specific to the FB7530 let alone flashing it from windows...

So what I would do is:

  1. failsafe boot
  2. reset the router to initial srate: firstboot -y
  3. reboot it: reboot -f
  4. log in via SSH and do:
  5. upload the missing firmware for the lantig devices again
  6. reboot
  7. log in again and configure the wan to use dsl0.2 and PPPoE (put in your required credentials)
  8. run 'opkg update ; opkg install luci' and log in via your browser
  9. configure the rest as you desire it

Hi! I deleted WAN (more or less) and replaced modem:

config interface 'wan'
        option device 'br-dsl'
        option proto 'pppoe'
        option username 'xxxx'
        option password 'xxxx'
        option ipv6 'auto'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

Do I need the wan6? It still states "device not present".
Thanks

This seems wrong, you really should use dsl0.2 here, assuming you want to use the 7530 as modem router.

I think I should not have posted my non-standard config at all, in spite of my attempts to comment it, it clearly got you onto a sub-optimal course.

Thanks @moeller0

@tmomas , could you please split this thread into another one since comment #3, because it has heavily been cannibalized now? I would appreciate it. Thanks

Noooooo! Your post made it possible for me to connect to the internet. That was great - thanks a lot! I need real life examples to compare against wikis etc to get an idea how things work. I can tweak it anyhow as soon as my understanding deepens.
See it from my side:
-) flashing the Fritz!Box 7530 with OpenWrt: pass
-) recovering after a bad network config: pass
-) switching to snapshot release: pass
-) connecting to the internet: pass
-) configuring the Fritz!Box to serve as SCHP client and DHCP server at th1e same time with different ports: pass

Thanks a lot! NOW it's time to optimize the network setting. I still don't understand why you consider it suboptimal. But hopefully eventually I can understand it.

You meant that I can get rid of the br-dsl and directly configure the modem as wan? I have to think that through and get behind your config.

So thanks again, highly appreciated.

KR

Split from the original thread @WotC's first post in this thread.

1 Like

@WotC I also told you to remove br-dsl and simplify it a few days ago. Getting DSL to work is really straight forward on this box.

As promised, I'm posting my 7520 config that I set up on the weekend - ISP is A1:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxx::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option tone 'b'
	option ds_snr_offset '0'
	option firmware '/lib/firmware/xcpe_8.D.1.C.1.7_8.D.0.E.1.2.bin'
	option annex 'b'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.17.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan.300'

config interface 'Management'
	option proto 'static'
	option device 'br-lan.1'
	option netmask '255.255.255.0'
	option ipaddr '192.168.20.1'

config interface 'Haustechnik'
	option proto 'static'
	option device 'br-lan.200'
	option ipaddr '192.168.18.1'
	option netmask '255.255.255.0'

config device
	option name 'dsl0'
	option macaddr xxxxxxxxx'

config interface 'wan'
	option proto 'pppoe'
	option device 'dsl0.2'
	option username 'xxxxxxxxx'
	option password 'xxxxxxxx'
	option ipv6 'auto'
	option keepalive '3 5'
	option peerdns '0'
	list dns '208.67.222.222'
	list dns '208.67.220.220'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan4:t*'

config bridge-vlan
	option device 'br-lan'
	option vlan '200'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'
	list ports 'lan4:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '300'
	list ports 'lan4:t'

Keep in mind that this uses VLANs! Interface LAN is on VLAN 300 and only port 4 receives it as a tagged VLAN (along with the otehr VLANs, that's my trunk port to the managed switch). Ports 1, 2 and 3 are untagged but are in the "Management" VLAN with ID 200. The firewall config is not included, but is set up so that all VLANs can access the internet but only VLAN 300 and initiate connections to the other VLANs.

If you want to separate just the ports, you do not need to mess around with VLANs as described here: https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial#multiple_bridged_networks