Replace wpad-mini with wpad-basic on TL-WR940N

I have a TL-WR940N router flashed with OpenWRT. It works, but I want to enable 802.11r, which is only available under wpad-basic. If I try to uninstall wpad-mini, no space is freed. I tried compiling OpenWRT from source but I keep getting errors e. g. ERROR: tools/flock failed to build.. Is there a way to completely remove wpad-mini and replace it with wpad-basic? The size of wpad-basic is only 26kB bigger than wpad-mini, so space wouldn't be an issue if I manage to remove wpad-mini and free up the space it takes.

Kind of expected, isn't it?

Yes, but wpad-basic should still fit

removing the old package won't actually free any flash space, you have to build your own image with the package replaced at build time.

and in

Customize installed packages and/or first boot script


-wpad-mini wpad-basic

have you tried looking for the WR940N in there ?

-> (


Yeah, the TL-WR940N is not there.

I know, that's why it was a bad advice.

Build your own image.

I tried, but keep getting errors like ERROR: tools/flock failed to build.. Can you help me build the image?

compile it with the -j1 V=sc options, to get further info, but with 18.06, you're pretty much on your own.

you could also try 22.03.3 tiny official(!) imagebuilder configuration for 4/32MB devices (ath79, TL-WA860RE v1 etc.), using ramdisk extroot too.

When trying to build the image using the Image Builder, I get this error: * opkg_install_cmd: Cannot install package wpad-basic.. I'm sure there's enough space, as wpad-basic is just 63kB bigger than wpad-mini and I have removed some packages that I will not need.

Also specify to delete wpad-mini: -wpad-mini. Otherwise it will try to include both and, space consideration aside, the build will crash as the two conflict with each other.

It's also likely that Image Builder 18 will fail to work since the package files it needs to download have been moved to the archive server.

I removed wpad-mini. I don't think there's a newer Image Builder that will work on my device.

So there's no way to compile an image with wpad-basic?