Repeated Reboots on Linksys E8450

Hey! I'm on firmware version of OpenWrt 23.05.2 r23630-842932a63d / LuCI openwrt-23.05 branch git-23.306.39416-c86c256

Not sure why, recently my router keeps restarting itself. Not sure how to find out what the issue is.

Let’s start with your config. My first guess is that this is a power issue, but we can check the software side first.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

This is the response I got!

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Linksys E8450 (UBI)",
        "board_name": "linksys,e8450-ubi",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "mediatek/mt7622",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3a:d0e6:7b65::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 'auto'
        option device 'wan'
        option username '103696319973'
        option password 'zvuC50MX'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option band '2g'
        option cell_density '0'
        option htmode 'HT40'
        option country 'IN'
        option noscan '1'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Prasanna'
        option encryption 'psk2'
        option key 'muthu123'
        list maclist '84:A9:38:9A:79:28'
        list maclist 'F8:5E:A0:E1:CA:CB'

config wifi-device 'radio1'
        option type 'mac80211'
        option he_bss_color '8'
        option he_su_beamformee '1'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option cell_density '0'
        option country 'IN'
        option htmode 'HE80'
        option channel '36'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Prasanna 5G'
        option encryption 'psk2'
        option key 'muthu123'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'Prasanna'
        option ip '192.168.1.130'
        option mac '98:48:27:82:EF:20'

config host
        option name 'Prasanna'
        option duid '00010001299CE49A18C04D5A3318'
        option mac '18:C0:4D:5A:33:18'

config host
        option name 'Prasanna'
        option duid '000100012A2C487F18C04D5A3318'
        option mac '18:C0:4D:5A:33:18'

config host
        option name 'Prasanna'
        option duid '000100012A838A0F04421A970798'
        option mac '04:42:1A:97:07:98'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        option masq '1'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option mtu_fix '1'
        list network 'wan'
        option masq '1'
        option input 'REJECT'
        option forward 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option target 'REJECT'
        option src 'lan'
        option dest 'wan'
        option name 'Loheth PC'
        list src_mac '84:A9:38:9A:79:28'
        list src_mac 'F8:5E:A0:E1:CA:CB'
        list proto 'all'
        option enabled '0'

Oh and btw my system log is spammed with lots of

DHCPDISCOVER
DHCPOFFER
DHCPREQUEST
DHCPACK

that's normal DHCP client activity.

1 Like

Alright got it!

Hey! It was a power issue afterall. The whole adapter box was filled with ants :skull:

I changed the adapter and it works now!

That is the funniest explanation for e8450/rt3200 troubles I have heard so far. :wink:

1 Like

from now on, every time someone creates a thread about firmware stability, 1st counter question will be "checked for ants ?".

1 Like

:rofl: oh btw maybe this might interest you, I am using Stubby for Cloudware DNS. But when I go to https://www.cloudflare.com/ssl/encrypted-sni/ for checking my browser, I don't see a tick mark for secure DNS.

Is there something that I need to change for it to work?

I followed this thread for setting it up : [Tutorial] [No CLI] Configuring DNS over TLS with LuCI using Stubby and Dnsmasq

1 Like

I agree with the comments - this is hilarious and some light relief for the ongoing issue that’s under investigation on the main thread for the device.

Don’t suppose you have any photos? I’m super curious.

Ants are supposed to be relatively easy to deal with. You place a few of these little stations that poison the entire colony.

When my Zyxel NR7101 failed to power up I initially suspected that mice had chewed through the PoE cable (which extends through circa one metre thick sandstone and an internal dry wall). On balance looking back I’m relieved that it turned out to be a defective unit and Zyxel have since replaced it under their RMA procedure. Better a defective router than a mice infestation, right?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.