Regular WiFi crashes on a Netgear WNDR4700 Centria with OpenWrt 19.07.5 r11257-5090152ae3

Hello Forum,

tried the first OpenWRT installation on my router - it was much easier than I assumed in the first place, but the WiFi connections crash every few days as already discussed in Netgear R7800 wifi internet connectivity drops - #17 by fantom-x with a similar model.

The slution in this another thread was to remove the Atheros device drivers and to replace them with customized ones - these drivers are not installed on my router, so in my case the solution must be different.

When the WiFi crashes the next time, I will post the dmesg output.

Thanks in advance,


Upgraded to 19.07.6 as been recommended, will continue observing.

Can you post the output of find /lib/firmware -type f ?

Like in this post:

Sorry, didn't look here for longer bc since update to 19.07.6, the crashes seem to be gone - didn't see any since then despite of all the observing and heavy router duty.

Here's my output of find /lib/firmware -type f:

root@OpenWrt:~# find /lib/firmware -type f

That's good news! May I suggest then that you mark your thread as solved?

1 Like

Due to Murphys Law, when I do that, the wi-fi will crash in the same moment (or at least as soon as Murphy allows to) :joy: :joy: :joy:

Well, however. I will mark the next-to-last answer as solution - should I do so?

Just as I said. The wi-fi connections were crashed while I typed the last message - but I dunno if it was bc of the same error. Our internet provider corrected some errors on our wire, so maybe it could have something to do with that.

Strangely, I was still able to login to my router from my mobile phone (via wi-fi, not via the WAN access) and restart the wi-fi devices - after that, the wi-fi devices were working again.

The router was off for 2 weeks... vacation. On Saturday,. I came back and turned it on again, after that the wi-fi worked in first place - til now:

[   70.625375] xhci_hcd 0000:45:00.0: firmware failed to load (-2).
[   70.631426] xhci_hcd 0000:45:00.0: Unloading driver

Logged in over the wire, restarted the "radio0" device, working again... but the crashes still persist :frowning:

Tried to upload the original NETGEAR firmware back over the web interface (sorry - cannot stand the crashes no more, stable wi-fi is imperative for my home work, and in these times I can only work from home).

After that, the device keeps rebooting. After answering to 2-3 pings it says "Request timed out" all the time, not reachable over web interface and SSH. Pressing and holding the reset button changes nothing... when I power off, hold the reset button and power on again, I get the power LED blinking green (=cannot boot, bad firmware). Turning off and on again - the same as before, keeps rebooting.

Had to read the section "Uninstalling OpenWRT" first... bricked with no chance? :sob: :sob: :sob:

Re-animated the router with TFTP and original software, at the moment, got my internet connection back.

Will maybe try a later release of OpenWRT when there is one.

Admins, please close the thread - thanks and bye.